TX2 USB not work on my custom board

I‘m sorry ,The problem is still unresolved,this is the dmesg log, please help me see
the main error:
[ 1.104066] tegra-xusb-padctl 3520000.xusb_padctl: failed to setup XUSB ports: -517
[ 1.157795] tegradc 15210000.nvdisplay: dc_hdmi_hotplug_init: couldn’t get regulator vdd_hdmi_5v0, -517
[ 1.388981] FAN: coudln’t get the regulator
[ 1.431749] ina3221x 0-0042: ina3221 reset failure status: 0xffffff87
[ 1.432352] ina3221x 0-0043: ina3221 reset failure status: 0xffffff87
[ 1.750486] tegra-xusb-padctl 3520000.xusb_padctl: failed to setup XUSB ports: -517
[ 3.852993] cgroup: cgroup2: unknown option "nsdelegate"
[ 11.509229] vdd-1v8: voltage operation not allowed
[ 11.518035] sdhci-tegra 3440000.sdhci: could not set regulator OCR (-1)

Maybe you should tell some detail about your board design and what efforts you have tried in your device tree.

Please don’t expect other people can easily understand your problem by just few words or brief log.

The board design is based on the official website documents ,and I tried to follow some posts to modify the dts file “tegra186-quill-p3310-1000-a00-00-base.dts”:
pinctrl@3520000 {
vbus-0-supply = <&vdd_usb0_5v>;
vbus-1-supply = <&vdd_usb1_5v>;
vbus-2-supply = <&battery_reg>;
vbus-3-supply = <&battery_reg>;
vddio-hsic-supply = <&battery_reg>;
avdd_usb-supply = <&spmic_sd3>;
vclamp_usb-supply = <&spmic_sd2>;
avdd_pll_erefeut-supply = <&spmic_sd2>;
};
but , Still have the same problem ,usb not work

You should follow the adaptation guide first, if you cannot tell the correctness of those posts.

TX2 dmesg log.docx (39.7 KB)
this is dmesg log ,thanks

Adaptation guidelines are also these methods ,I have seen

Which adaptattion guide are you referring to? Which jetpack release are you using?

Jetson_Linux_Driver_Package_Release_Notes_R32.3.1_GA.pdf (547.3 KB)
jetpack 4.3

Tegra_Linux_Driver_Package_TX2_Adaptation_Guide.pdf (548.8 KB)
sorry ,Should be this

Did you ever read “Porting USB (Universal Serial Bus)” section? That is the one you should check.


excuse me ,in the" jetson TX2 Platform Adaptation and bring-up Guide "document,Figure 7 USB OTG ID pins,not use the USB0_VBUS_DET on my custom board , See the uploaded image for details,not using this pin ,if that would be a problem?

You can follow the document to write your own extcon status table to control this port without the ID pin.

My colleague checked the“Porting USB”,Didn’t find anything,all follow the document,so I don’t know what could be the reason, First time using TX2, not familiar with it

This table from the document is the extcon table.If there is no USB0_VBUS_DET in use on your port, then write a new table for your usecase.

This is standard linux kernel driver. Not NV use only.

ok,thanks,and look the dmesg log USB is not powered up, I don’t know if it is related to hardware or software

Then you can share the dmesg, board schematic and current dts files. We are not your co-worker, so know nothing about your board.
There were lots of users also saying “our board is based on official document”, but turns out the cases are different.