TX2 with J120 and intel realsense D435i USB 3.0 problem

I’m using TX2 on J120 (from Auvidea) and trying to attach the D435i to USB 3.0 port (upper port)
for specification:

  • Jetson TX2
  • Ubuntu 18.04
  • Jepack 4.2 (L4T 32.1)
  • Linux nvidia 4.9.140-tegra
  • D435i with USB 3.0 cable
  • Auvidea J120 carrier board

When I run ‘realsense-viewer’, the D435i camera is recognized as USB 2.0 (I tried upper and lower port both) while RGB-D images and other things are correctly activated
I saw many article about this problem, but no one has solved…

try1) Someone said there need to be kernel patched. So I also tried according to this link: https://github.com/Tengyun-Mo/buildLibrealsense2TX2
(using proper kernel patch scripts)

But still USB 2.0 recognization…

try2) Intel realsense said there doesn’t need to be kernel patched nowadays. So I tried according to this link: https://github.com/IntelRealSense/librealsense/blob/development/doc/installation_jetson.md
(this doesn’t do kernel patch)

But still USB 2.0 recognization…

Could anyone give me an advice … ? I’m stucked in this problem for a month… I should use ubuntu 18.04 and Jetpack ver.4.2 for my research please help me…

Hi Zinuok,

first we need to know if you use our auvidea image? If yes, which version do you use and which USB port are you using?

Best regards,