TX2NX Pinmux changes not applying

Hello!

So I needed to update my pinmux to enable I2S3 but it doesn’t seem to work. First of all, the pin states are incorrect when I export GPIO in user space (direction)
Here are the steps I did:

  1. Backup my existing system.img via flash.sh script:
    sudo ./flash.sh -r -k APP -G backup.img jetson-xavier-nx-devkit-tx2-nx mmcblk0p1

  2. Exported .dtsi from Excel Pinmux (obviously I enabled I2S3 in the Excel, it was GPIO before) and made .cfg file via pinmux-dts2cfg.py

  3. Moved my backup to bootloader as system.img
    mv backup.img.raw bootloader/system.img

  4. Moved .cfg file to BCT folder and flashed the whole Jetson TX2NX
    sudo ./flash.sh -r -k APP jetson-xavier-nx-devkit-tx2-nx mmcblk0p1

  5. After the flash there were stock kernel and stock DTB, so I used flash.sh script to flash them one by one.
    sudo ./flash.sh -r -k kernel -K kernel/Image jetson-xavier-nx-devkit-tx2-nx mmcblk0p1
    sudo ./flash.sh -r -k kernel-dtb -d kernel/dtb/tegra186-p3636-0001-p3509-0000-a01.dtb jetson-xavier-nx-devkit-tx2-nx mmcblk0p1

So if I export the GPIO, which I know, should have direction output. cat /sys/class/gpio/gpio417/direction says it’s in not out.

What am I doing wrong here? I am not overriding any of those pins in DTS.

T186/T194 SoC (TX2/Xavier) are using the cfg file to handle the pinmux setting instead of the dtb file.

Those cfg files have their own partition and none of your above commands ever flash to this partition. So your change was not there as expected.

1 Like

So what is the command to flash that partition?

There is no command to flash BCT only. Need to do full flash.

1 Like

Okay, so it should be simply - sudo ./flash.sh jetson-xavier-nx-devkit-tx2-nx mmcblk0p1 ?

If your use case is just GPIO, and if the problem is just the direction is not correct, I don’t think you need to re-flash the board. Even the sysfs can change the direction.

1 Like

Nope, it’s not just GPIO, it’s also changing the function. So I need to reflash.

Ok, then you can only use the flash.sh command as your comment.

1 Like

Thanks! :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.