Using spreadsheet to set pinmux is not workable on r28.1 with TX2

Hi Sir/Madam,

I follow NV document to use spreadsheet to config pinmux but the setting isn’t applied.
(Original spreadsheet has errors so I use updated spreadsheet as following link)

Here are the steps I use

  1. Use “Jetson-TX2-Generic-Customer-Pinmux-Template (3).xlsm” and “mandatory_pinmux.txt” in the following link.

  2. Generate three DT files from “Jetson-TX2-Generic-Customer-Pinmux-Template (3).xlsm”

  3. dos2unix to convert files

  4. Copy step2 three files and “mandatory_pinmux.txt” to Linus_for_Tegra/kernel/pinmux

  5. python --pinmux addr_info.txt gpio_addr_info.txt por_val.txt mandatory_pinmux.txt tegra18x-jetson-tx2-config-template-pinmux.dtsi tegra18x-jetson-tx2-config-template-gpio-default.dtsi 1.0 > tegra186-quill-p3310-1000-a00-pinmux-gpio.cfg

  6. python --pad pad_info.txt tegra18x-jetson-tx2-config-template-padvoltage-default.dtsi 1.0 > tegra186-mb1-bct-pad-quill-char-e3301-1080-a00.cfg

  7. cpoy tegra186-quill-p3310-1000-a00-pinmux-gpio.cfg and tegra186-mb1-bct-pad-quill-char-e3301-1080-a00.cfg to Linux_for_Tegra/bootloader/t186ref/BCT

  8. sudo ./ jetson-tx2 mmcblk0p1

I also check the flash log, the two .cfg files not be flashed. Please check the attachment.

  1. tegra186-quill-p3310-1000-a00-pinmux-gpio.cfg
  2. tegra186-mb1-bct-pad-quill-char-e3301-1080-a00.cfg

Is to use spreadsheet to config pinmux workable on r28.1 with TX2?


flash.log (244 KB)

Thanks JasonFan!

We will investigate this issue and update to you.

Hi everyone.

I have also same problem.
I compared CAM0_RST GPIO signal by scope at boot time.
TX2 DevKit and my board signal appear reversed from each other.
So i worked for modify BCT and kernel dt.

Kernel device tree modify is worked,
but BCT modify is not worked.