Uart loopback reads blank and echo stuck

hey, i am using the tx2 dev board and i tried to loopback uart (jumper between pins 9 and 10). at first it kinda worked:

in one terminal:
echo “hello” > /dev/ttyS0

in anther terminal:
cat < /dev/tyS0

output was a little scrambled:

the port is set to 9600 baud ( checked with stty ) base_baud is 25500000.
but now it only reads blank over and over and the echo does not go threw.

Could you try baud rate=115200?

same, when i do “cat < /dev/ttyS0” it just reads blank nonstop

Please check relevant posts:
Enabling serial console (/dev/ttyS0) in TX2 - #2 by JerryChang
Serial ports (UART) on the Jetson TX2 and Nano - #10 by shgarg

Please try to connect to host PC and run minicom(or cutecom) to get debug log and execute commands. This is the default mode and shall work fine.

1 Like

hey i didn’t understand how to use ttyTHS1, is it the same pins? how do i use it instead of ttyS0?

when i try it with ttyTHS1 it doesn’t work at all

Each UART is compatible with either the legacy driver (producing naming convention “ttyS#”) or Tegra High Speed driver (producing naming convention “ttyTHS#”). Typically (probably not a guarantee), if it is the same “#” for both, then it would be the same UART/pins. Just don’t use two drivers simultaneously on the same UART.

I also suggest using a serial console program, e.g., gtkterm or minicom to test for echo in loopback since it is more likely to have all settings correct, and to also give an easier way to change settings.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.