UART2 on J90

Using JetPack 3.3 on a J90 firmware version 1.6 patched to get USB3 working, I’m having trouble getting the UART2 port working. I tried both connecting TX and RX together as well as a USB cable to a PC. Currently /dev/THS1-3 are showing up as devices, however, these aren’t showing any output on /dev/THS1-3 or /dev/S0-3 using minicom.

UART0 works on /dev/ttyS0 on the J90, but we can’t use that as it is console and not DMA.

I also tried it on the dev board J17 and I’m not getting anything there either. If I flash with the device tree of the J90 does this break the dev board’s interface?

From much reading on the forums, there are patches to get the UART working, but I think most of them don’t apply to the versions I’m using, is this correct, or do I need to patch something to get this working? I’m not entirely sure where in the device tree to look to make sure it is enabled/mapped properly, could I get some pointers?


Edit: Dev board J17 UART1 does work with both the jetpack 3.3 default flash and the J90 firmware changes. Still can’t get J90 uart to work with their firmware or a built one from their sources.

From the J90 spec:
“UART2_TXD / SWCLKB16UART 0 console port (3.3V TTL level): transmit data output (RN24 must be installed) J90 with MCU: SWCLK”

What is RN24? Also, it is labeling uart2 port as uart0 console… Is that a typo? (Both UART0 and UART2 ports in the description say UART0 console…

Hi, you’d better to ask vendor of J90 for help. For TX2, all ports are validated before ship out.

I submitted a ticket with them, waiting on a reply.

Is there a way to verify uart2 on the dev board? The only header I saw was on the m2 connector. I suppose I could try getting the camera working as it is on uart2.

Hi acwatkins, your ticket has been answered.

But for everybody else that wants to get UART2 to work, please populate the spot marked as RN24 with a 0 or 10 Ohm resistor (we use EXB-N8V100JX).

Hi everybody,

are you serious ???

you says that we do put a micro-resistor to obtain the uart_tty2 working ?

seem’s you have write the in your documentation and website that it was available :

The “J90” is the fully featured version: 2x UART, 2x CSI-2.

And how did we realise this modification in our kitchen ???