Ubuntu 16.04 kernel 4.13.0-43, driver 390.25 (or 396), vcard: GTX 1060: The system is running in low-graphics mode

Hello everyone, I’m ready to give now but here are the details:

AMD Ryzen CPU X1600, X370 chipset (no embedded video card)
secure boot off
monitor connected through display port

Ubuntu 16.04 with 4.13.0-43 kernel (all updated/upgraded)
390.25 driver installed through PPA (396 even worse)
nouveau disabled through modprobe.d file (as recommended) plus
CUDA not involved - did not even try

kernel startup flags

/boot/vmlinuz-4.13.0-43-generic.efi.signed root=UUID=XXX ro quiet splash nouveau.modeset=0 grub_gfxmode=vesa rdblacklist=nouveau vt.handoff=7

tried wo grub_gfxmode=vesa as well

dmesg | grep nvidia

[    1.102143] nvidia: loading out-of-tree module taints kernel.
[    1.102148] nvidia: module license 'NVIDIA' taints kernel.
[    1.108726] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    1.146669] nvidia-nvlink: Nvlink Core is being initialized, major device number 242
[    1.146946] nvidia 0000:1d:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem
[    1.169085] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  390.59  Wed May  9 21:59:27 PDT 2018
[    1.169638] [drm] [nvidia-drm] [GPU ID 0x00001d00] Loading driver
[    1.169640] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:1d:00.0 on minor 0
[    2.556906] nvidia-uvm: Loaded the UVM driver in 8 mode, major device number 240
[    4.474767] nvidia-modeset: Allocated GPU:0 (GPU-80c6c27c-272c-f670-4a6b-0ddef4992cb5) @ PCI:0000:1d:00.0
[    4.971648] nvidia-modeset: Freed GPU:0 (GPU-80c6c27c-272c-f670-4a6b-0ddef4992cb5) @ PCI:0000:1d:00.0
[   14.638972] nvidia-modeset: Allocated GPU:0 (GPU-80c6c27c-272c-f670-4a6b-0ddef4992cb5) @ PCI:0000:1d:00.0

xorg.conf generated with nvidia-xconfig or no file at all

No login screen, The system is running in low-graphics mode error, which won’t let you through (even with fallback mode). No errors in Xorg.log, but this for every video port. Can switch to terminal though.

config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event15)

Obvious question - what is wrong with my system? And how to fix. I’ve spent quite a while going through various howto and forum threads - to no luck.



| NVIDIA-SMI 390.59                 Driver Version: 390.59                    |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce GTX 106...  Off  | 00000000:1D:00.0  On |                  N/A |
|  0%   28C    P8     7W / 200W |     16MiB /  6075MiB |      0%      Default |
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|    0      1464      G   /usr/lib/xorg/Xorg                            14MiB |

No errors in kernl.log
Xorg.0.log (21.3 KB)
lightdm.log (151 KB)

Driver version 396 has a bug with certain gtx1060 so don’t use that.
The driver 390 you’re using currently is fine, the problem you’re facing is that lightdm can’t authenticate the greeter to its own Xserver.
Try purge/reinstall lightdm.

Thanks a ton, generix!

Switched my focus to lightdm setup and was able to get X server working. But only with gdm3 display manager, selecting lightdm from

dpkg-reconfigure lightdm

leads to the same error.

Moreover even though unity-greeter is selected, initial login screen looks very poor, resolution is fine though (appears to be gdm3 greeter). If I do log out I’ll get regular unity-greeter UI. But not initially.

Ok, one of lightdm config files had a reference to non existent script. Finally, fully figure and fixed!