Stuck in login loop after system crash - Ubuntu 16.04 Nvidia GT1030

So it has been a while since I got the big freeze that messed up my ability to login through the lightdm GUI. Everything works underneath the surface, my server is running fine and can be accessed anywhere. But I just can’t login as long as there is an nvidia driver installed on the system. As a tty-user it works though… but can’t enter desktop.

I have purged existing drivers and everything related to nvidia. After that login worked perfectly again. Then installed latest drivers (nvidia-430) for my card GT 1030 and the problem came back.

Sending the requested nvidia-bug-report.log


nvidia-bug-report.log (195.5 KB)

You’re running a 5.5 kernel compiled with gcc 9.2 but your system compiler is gcc 5.4 so no kernel module will compile. For the 5.5 kernel, you’ll need a 440.82 driver.
The repo/ppa driver 430 is broken anyway, never worked due to 16.04 being a non-glvnd system.
Where to begin?

I’ll start by saying this: I’m new to Linux and Ubuntu so this is kind of my first try getting a proper system running on it. I’ve set it all up using guides and tricks from others. Anyways, this crashing problem is something that has been bothering me for a while, and so I read somewhere that upgrading to a newer kernel would add better support for Ryzen CPUs. So I followed a linke to the ubuntu kernel repo and installed the latest 5.5 kernel. The install however failed so I cancelled my attempts to get it going due to the fear of breaking anything…

May it be that it installed and in that way broke my system? I did not reboot after it failed, but I have my system set to reboot every morning at 4am.

Are you able to help me revert this?

It’s simply the driver package from the graphics driver ppa, it’s incorrectly packaged. The fix for it is easy but using Ubuntu 16.04 in conjunction with a nvidia gpu is a dead end, imho. It has an outdated graphics driver layout (non-glvnd). You should rather upgrade to 18.04.

1 Like

I rolled back to kernel 4.1.5 and installed nvidia-384 driver through ubuntu rep. Now everything is working as it should. Thanks for leading me in the right direction

For completeness, how to fix the broken 430 driver from ppa: