Ubuntu 20.04 doesn't recognise Nvidia driver

I was trying to play Civilization VI with my friends and it didn’t work. I tried several things and possible I have a lot of damaged libraries and so on.
When I start it, the screen goes black and that’s it.

Couldn’t use in Windowns virtual machine, because epic game store is very slow for some reason.

Anyway, despite of software manager recognization of Nvidia software, as I use nvidia-smi, that’s my answer:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I tried what was said in here (Ubutun 20.04 driver 440 installed but can't enable nvidia GC), but now I am receiving various errors messages from Ubuntu. The system seems to be working fine.

Thanks

More information:
glxinfo | grep render
direct rendering: Yes
GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
GLX_MESA_copy_sub_buffer, GLX_MESA_query_renderer, GLX_MESA_swap_control,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa Intel® UHD Graphics 620 (WHL GT2)
GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted,
GL_IBM_multimode_draw_arrays, GL_INTEL_blackhole_render,
GL_NV_conditional_render, GL_NV_copy_image, GL_NV_depth_clamp,
GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted,
GL_INTEL_blackhole_render, GL_INTEL_performance_query,
GL_NV_compute_shader_derivatives, GL_NV_conditional_render,
GL_EXT_read_format_bgra, GL_EXT_render_snorm, GL_EXT_robustness,
GL_EXT_texture_view, GL_EXT_unpack_subimage, GL_INTEL_blackhole_render,
GL_NV_conditional_render, GL_NV_draw_buffers, GL_NV_fbo_color_attachments,
GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

sudo lshw -c video
*-display
descrição: VGA compatible controller
produto: UHD Graphics 620 (Whiskey Lake)
fabricante: Intel Corporation
ID físico: 2
informações do barramento: pci@0000:00:02.0
versão: 02
largura: 64 bits
clock: 33MHz
capacidades: pciexpress msi pm vga_controller bus_master cap_list rom
configuração: driver=i915 latency=0
recursos: irq:128 memória:a2000000-a2ffffff memória:80000000-8fffffff porta de E/S:5000(tamanho=64) memória:c0000-dffff
*-display DISPONÍVEL
descrição: 3D controller
produto: GP108M [GeForce MX150]
fabricante: NVIDIA Corporation
ID físico: 0
informações do barramento: pci@0000:02:00.0
versão: a1
largura: 64 bits
clock: 33MHz
capacidades: pm msi pciexpress bus_master cap_list
configuração: latency=0
recursos: memória:a3000000-a3ffffff memória:90000000-9fffffff memória:a0000000-a1ffffff porta de E/S:4000(tamanho=128) memória:a4000000-a407ffff

nvidia-bug-report.log (838.8 KB)

Please follow this:

  • make sure nvidia-prime is installed (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot
    If this doesn’t resolve the issue, please create a new nvidia-bug-report.log.

I tried to install nvidia prime, but the system crashed, then it just didn’t start anymore. The
I didn’t know what to do, so I made a fresh start with Pop OS 20.04. Drivers seems fine now and I got back where I started. Civilization VI opens and say loading shaders and doesn’t continue.

nvidia-bug-report.log (2.0 MB)

Installation is fine, driver fully functional. You might want to run Civ 6 in terminal to see if any errors show up.