Ubuntu 22.04 With mx150 graphic card shows no devices were found

Hi, I have Ubuntu 22.04.3 LTS (6.2.0-33-generic) installed on my Ideapad 320 laptop. and my graphic card is Nvidia Mx150 and currently im using nvidia driver metapackage nvidia-driver-525 (proprietary)

Little bit of background :

okay so my nvidia driver usually would get broken after reboot or after a update at least once per month or sometimes 1-3 times per week. and i usually could fix the problem by just simply reinstalling my nvidia driver and rebooting my laptop and my issue would get fix…
but from yesterday i was gaming and my laptop froze and then i hat to shutdown manually from my laptop button, and then after that reinstalling nvidia driver couldnt fix my problem!
and im really really stucked.

My actual issue :

basically my drivers are not working and not recognizing my graphic card,
when i Run nvidia-smi it says

No devices were found

and If i run nvidia settings it launches but gives some error too in terminal :

ERROR: A supplied argument is invalid

(nvidia-settings:9902): GLib-GObject-CRITICAL **: 13:04:57.614: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

** (nvidia-settings:9902): CRITICAL **: 13:04:57.616: ctk_powermode_new: assertion '(ctrl_target != NULL) && (ctrl_target->h != NULL)' failed
** Message: 13:04:57.658: PRIME: Requires offloading
** Message: 13:04:57.658: PRIME: is it supported? yes
** Message: 13:04:57.697: PRIME: Usage: /usr/bin/prime-select nvidia|intel|on-demand|query
** Message: 13:04:57.697: PRIME: on-demand mode: "1"
** Message: 13:04:57.697: PRIME: is "on-demand" mode supported? yes

and when the nvidia-settings launches, it only have three Options which are

  1. Application profiles
  2. nvidia-settings Configuration
  3. PRIME Profiles

i remember when my driver was working fine, i had more options…
And i tried switching To Performance mode too which is same and still i get no devices were found output when i run nvidia-smi.

and by the way when i run lspci i can clearly see my graphic card in the list :

01:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX150] (rev a1)

Things i tried :

i tried reinstalling nvidia driver.
i tried switching other kernels
i tried different nvidia drivers such as 535 and 470
i reinstalled headers : sudo apt reinstall linux-headers-$(uname -r)
i tried so many other solutions that i could find on the internet which i dont even remember.

and my issue still persisting!

note that may be useful : my secure boot is disabled and fast boot is also disabled

i tried to upload logs but idk why its stuck on Processing Upload!!!

Processing: nvidia-bug-report.log.gz…

im sorry but i tried maybe more than 6-7 times to upload my Log file but it get stuck on Processing upload file…
so i uploaded it on discord