Ubuntu account issue (username: nvidia, password: nvidia) for TX2 and ConnectTech's Orbitty.

Hi,
I faced Ubuntu account issue on my TX2 with Orbitty carrier board.
Below are software versions I am using;

  • Jetpack 3.0 (JetPack-L4T-3.0-linux-x64.run)
  • BSP, CTI-L4T-V103.tgz
  • R27 (release) Revision: 1.0

I followed instructions provided by ConnectTech (readme.txt from CTI-L4T folder).
Images were successfully flashed and I could see ubuntu screen and simple usb devices worked (keyboard and mouse).
However, whenever I tried to run “sudo” related commands such as apt-get update (nvidia account), it complained “sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set”.

The reason is /usr/bin/sudo command sets as owner=“ubuntu” and group=“root”, nvidia account thus can’t use sudo command.

If I connect to the board via ssh with “ubuntu” account (username: ubuntu, password ubuntu), “apt-get update” worked but “sudo apt-get update” didn’t (same privilege error as above).

Eventually, I couldn’t use any commands that locate under /usr/bin and many other applications.
Anyone faced this similar issue?
Cheers,

Whenever a system is flashed you must preserve permissions of the sample rootfs as well as any other commands modifying the file system (such as apply_binaries.sh). sudo is used for this. The other issue is that the host’s own file system must use a native Linux file system type such as ext4, or else it is not possible to preserve permissions (e.g., a flash drive with VFAT or a VM on NTFS will always fail this way). My guess is it needs to be re-flashed and carefully make sure any file unpacking and flashing steps use sudo where needed.

Hi, linuxdev
Thank you for your comment and I could resolve the issue.
This happened due to Jetpack installtion with sudo command.
I ran “sudo JetPack-L4T-3.0-linux-x64.run” but shouldn’t do this as mentioned here (http://docs.nvidia.com/jetpack-l4t/#developertools/mobile/jetpack/l4t/3.0/jetpack_l4t_install.htm).
Instead just installing JetPack on my ubuntu host machine without sudo and it asked password while installing.

Now all permissions were preserved and it works.
Thanks for your comment again.
Cheers,