Ubuntu - nvidia-smi No devices were found

Hello
I bought KFA2 GeForce RTX 2060 SUPER Mini for my home server:

AMD Ryzen 3 3200G AM4
Gigabyte B450M DS3H AM4 (BIOS F50)
G.Skill Aegis DDR4 32GB (2x16GB) 3000MHz CL16
PSU Vero M2 Bronze 600W

system:

ravnica@ravnica:~$ uname -a
Linux ravnica 5.3.0-40-generic #32-Ubuntu SMP Fri Jan 31 20:24:34 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

ravnica@ravnica:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 19.10
Release:        19.10
Codename:       eoan

i wanted to use that GPU for tensowflow and keras so i’ve installed all things that were requiered and get this:

ravnica@ravnica:~$ nvidia-smi
No devices were found

More info:

ravnica@ravnica:~$ sudo lshw -C display
  *-display
       description: VGA compatible controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:65 memory:f6000000-f6ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:f000(size=128) memory:f7000000-f707ffff
  *-display
       description: VGA compatible controller
       product: Picasso
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:08:00.0
       version: c9
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix vga_controller bus_master cap_list rom
       configuration: driver=amdgpu latency=0
       resources: irq:74 memory:e0000000-efffffff memory:f0000000-f01fffff ioport:d000(size=256) memory:f7500000-f757ffff memory:c0000-dffff

ravnica@ravnica:~$ cat /proc/driver/nvidia/gpus/0000\:01\:00.0/information
Model:           Unknown
IRQ:             79
GPU UUID:        GPU-????????-????-????-????-????????????
Video BIOS:      ??.??.??.??.??
Bus Type:        PCIe
DMA Size:        47 bits
DMA Mask:        0x7fffffffffff
Bus Location:    0000:01:00.0
Device Minor:    0
Blacklisted:     No


ravnica@ravnica:~$ lspci -k | grep -EA3 'VGA|3D|Display'
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1f06 (rev a1)
        Subsystem: NVIDIA Corporation Device 13a3
        Kernel driver in use: nvidia
        Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
--
08:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso (rev c9)
        Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Picasso
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu

So what should i do in this case go get this gpu work?nvidia-bug-report.log (323.8 KB)

There seems to be something wrong with the hardware, the driver can’t initialize the gpu:
RmInitAdapter failed! (0x25:0x40:1199)
Try reseating the card in its slot (pull it out, put it back in), check if all power cables are properly connected, reseat them as well. Looking for an updated system bios is always worth a shot.
If nothing helps, please check if the card is faulty in another system and RMA.

1 Like

Thanks for replay!
Reseating gives same result. I put this GPU into another PC with Windows 10 and it gives me Code 43 - so i guess RMA.