UNable to flash NX

I’m unable to flash the NX using the SDK Manager. Attached is the log from the SDK Manager Terminal.

terminal_log_flash_nx.txt (5.7 KB)

hello aidev,

could you please attach full flash messages for reference, especially that reading RAMCODE from backup chip_info.bin file,
you may perform flash.sh to re-flash the board with the JetPack release image locally.
thanks

Hi @JerryChang, are there any insytrcutions as to how to flash it locally. I am using nx module and aetina an810 carrier board. I usually plug in the power and connect the microusb to flash the jetpack.

hello aidev,

you may setup an environment with NVIDIA SDK Manager to download NVIDIA JetPack SDK. it’ll install the release image to your local host, you may also enable flash script to re-flash the board.
please also check developer guide for the Flash Script Usage.

BTW,
you cannot use both modules (Nano, Xavier NX) with the same carrier board, please also refer to Topic 144055 as see-also.
thanks

Hi @JerryChang
I tried to reflash again and got the output from the serial and SDKManager
From serial output everything looks fine, but seems like it keeps failing.

flash-Output.txt (41.2 KB)
SDK-Output.txt (9.4 KB)

It looks like the process failed while writing one of the partitions. You may have a USB connectivity or power issue. First. make sure you’re powering the device from the barrel jack and that it’s a properly sized power supply and make sure there’s a jumper on the pins between the barrel jack and the video connector stack. Then I’d change out the USB cable and plug it into a different port on your host.

EDIT: Oops, I just saw you’re not using the DevKit carrier board. Are you using the DevKit NX module with the SDCard or the production module with the soldered in eMMC?

hello aidev,

please check Flash Script Usage,
could you please generate image locally with the following command-line,
for example, $ sudo ./flash.sh --no-flash jetson-xavier-nx-devkit-emmc mmcblk0p1

after image creation complete. it’ll also create the flashcmd to your host machine, the generated command line is calling tegraflash.py python script for flashing the platform.

please also have a try,
thanks

Hi @JerryChang
I tried the command you indicated and I have attached the logs from both the flash and UART outputs.
Thanks.

flash-Output-serial-manual.txt (18.9 KB)
manual-flash-Output-avtar.txt (62.8 KB)

hello aidev,

since the system.img has built successfully to your local host machine,
could you please have a try to perform image flashing through flash commands directly? (i.e. flashcmd.txt)
for example,

saving flash command in /home/aidev/nvidia/nvidia_sdk/JetPack_4.4_Linux_JETSON_XAVIER_NX/Linux_for_Tegra/bootloader/flashcmd.txt
saving Windows flash command to /home/aidev/nvidia/nvidia_sdk/JetPack_4.4_Linux_JETSON_XAVIER_NX/Linux_for_Tegra/bootloader/flash_win.bat

Hi @JerryChang
Just tried it and see the output… Same error code :(
flash-Output-manual-sh-flashcmd.txt (17.8 KB)

@JerryChang - I’m using Aetina Carrier Board AN810 with NX Production board.
I have removed the micro-SD Card and NVME to ensure they are not causing any issues with the flashing.
I tried to flash it using Jetpack 4.4.
I’m working on a Ubuntu Laptop with v18.04.

so, the board name should be something different as Xavier NX DevKit, jetson-xavier-nx-devkit-emmc.
for example, $ sudo ./flash.sh <board> <rootdev>

there should be some difference for the carrier board, please contact with Aetina for the board configuration files,
thanks

@JerryChang
I tried to use the patch from Aetina for AN810-XNX…
But I still end up with the same error. Based on documentation, for flash should be jetson-xavier-nx-devkit-emmc as for Jetson Xavier NX P3668-0001 module… and the instructions say use command:
sudo ./flash.sh ${BOARD} mmcblk0p1

I got the patch and executed setup.sh which copied the files to rootfs and then I flashed suing the same syntac and ended with same error.

Re: https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/quick_start.html#wwpID0EAAMNHA

hello aidev,

please also check Xavier NX’s general flash configuration file, p3668.conf.common.
there’re serval configuration files, do the patch from Aetina overwrite them?
otherwise, you may check if they’re provided another flash configuration file for flashing the board.
thanks

@JerryChang - so here’s one observation which I am a little confused on.
When I’m flashing the nx module using the SDK, on step 1 it recognizes that I have the nx module. So, I select my jetpack 4.4 and go to step 2. I click on checkbox for acceptance of download folder and click on next at which stage it asks me for sudo password. Once the download begins and it creates the o/s image, it starts flashing right away. It never asks me if I want to do an automatic setup or a manual setup. In the past I remember entering a user name or password and selecting automatic/manual setup. It keeps trying to flash and keeps failing with the same error message.
I asked the vendor and I ran their patch before the flash and it still fails. I tried to flash manually using the following
sudo ./flash.sh jetson-xavier-nx-devkit-emmc mmcblk0p1
and it still failed.
Thoughts? I’m a little confused as to why it keeps failing and unable to determine if it is carrier board at fault or the nvidia production nx board? Any way we can determine that or rule out one or the other?

hello aidev,

to clarify, by using NVIDIA SDK Manager, it’ll install the default JetPack release image.
in other words, please enter the environment path, overwrite the configuration files and perform the flash.sh scripts for flashing the customize image.
thanks

@JerryChang - When I flashed it first time, I never had to change any config files. I flash it using the default JetPack release.

hello aidev,

is it a Jetson Xavier NX DevKit, or, you’re actually having different carrier board from your vendor?
default JetPack release image should only works with default Jetson platforms.

@JerryChang - I have the aetina nx carrier board (an810-xnx) and nx module.

hello aidev,

you may duplicate the image flash with the JetPack release, which has downloaded to your local host,
for example, ~/nvidia/nvidia_sdk/JetPack_version_platform/Linux_for_Tegra/

you may also check the developer guide, Flashing and Booting the Target Device.
please using flash.sh to perform image flashing, please also contact with Aetina for the board configuration files and further supports.
thanks