Unable to Flash Orin Nano Dev Kit SSD with SDK Manager


I’m trying to flash Jetpack 5.1.1 onto some Orin Nano dev kits directly to the NVMe SSD without using an SD card, but the OS flash keeps failing. I’ve tried a number of suggestions I’ve seen on similar threads including trying different USB cables and formatting the SSD to have a single ext4 partition to no avail. I’m using a clean native install of Ubuntu 20.06 LTS and SDK Manager 1.9.2. My log files are attached below.

Does anyone know what the issue might be?

SDKM_logs_JetPack_5.1.1_(rev._1)_Linux_for_Jetson_Orin_Nano_modules_2023-07-05_11-33-49.zip (190.3 KB)



can you help to dump UART log when the device fails to be flashed?
You may also try flashing to an SD card/USB drive, and if you can succeed with them, then maybe there’s some issue with the SSD you use.

So I actually got it to work with sdk manager 1.9.2 by using the docker container on Arch Linux, but now with the forced update to 1.9.3 sdk manager does not recognize the USB device in recover mode even though it’s showing up as “0955:7523 NVIDIA Corp. APX” when I run lsusb in the docker container.

Any ideas on how to fix this? It kind of seems like an issue with SDK manager 1.9.3 as it worked with the exact same system and the exact same container before the forced update. I also tried this with a new container and had the same issue.

How will it turn out if you flash it in the script way? (using initrd flash provided in our BSP)
Also, did you use our official docker image for SDK Manager?

I did use the official docker image. Funny enough, although the 1.9.3 update broke the docker method, the regular GUI method in Ubuntu 20.04 now works with the 1.9.3 update. I should be able to do everything I need with that. Thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.