Unable to flash u-boot for enabling PCIe

I am trying to enable PCIe on a TX2 module with custom carrier according to this thread:


Some very clear steps on how to apply this update would be helpful. I am unable to flash u-boot due to an error. I am attempting to flash via the devkit carrier.

I have tried several variations, but my core steps were:

  • update Linux_for_Tegra/bootloader/t186ref/BCT/tegra186-mb1-bct-pmic-quill-p3310-1000-c03.cfg with file from thread
  • make u-boot in Linux_for_Tegra/sources/u-boot/
  • copy u-boot.bin to Linux_for_Tegra/bootloader/t186ref/p2771-0000/500/
  • flash with the command provided in the thread:
sudo ./flash.sh -r -k EBT jetson-tx2 mmcblk0p1

This command runs through a lot of packaging steps, but at the end, it produces this error:

[  13.3268 ] Writing partition
[  13.3285 ] tegradevflash_v2 --write EBT /home/.../TX2_3.0/64_TX2/Linux_for_Tegra_tx2/bootloader/signed/nvtboot_cpu.bin.encrypt
[  13.3299 ] Bootloader version 01.00.0000
[  13.6995 ] File to be written cannot be of zero size
[  13.6995 ] 
Error: Return value 10
Command tegradevflash_v2 --write EBT /home/.../TX2_3.0/64_TX2/Linux_for_Tegra_tx2/bootloader/signed/nvtboot_cpu.bin.encrypt
Failed to flash t186ref.

Hi readonly,
Please also refer to

Does it work if you flash with default u-boot?

With the default u-boot, I get the same error:

File to be written cannot be of zero size

Error: Return value 10
Command tegradevflash_v2 --write EBT /home/…/TX2_3.0/64_TX2/Linux_for_Tegra_tx2/bootloader/signed/nvtboot_cpu.bin.encrypt

It seems that the file bootloader/signed/nvtboot_cpu.bin.encrypt does not exist.

I ended up having to flash the whole filesystem, which got the MB1 config applied successfully.