unable to get hybrid graphics working in linux without unofficial solutions

I have a laptop with hybrid graphics that needs both GPUs running in order to cool the system correctly, if the intel GPU is off then its fan does not run followed by my computer overheating. The problem is that I haven’t been able to get both cards running unless I use bumblebee, but it does not support vulkan, which I need for most of my games to work. I was able to get vulkan to work with bumblebee by using primus-vk, the problem with this is that primus-vk is very limited and I loose so much performance that it feels like I am using an intel 4000 card rather than a GTX 1060 even with my games on lowest settings.

I am getting really irritated because I have a nice GPU, but I am limited to the performance of a really low end computer. That or I burn myself playing followed by throttling and my computer shutting itself off to prevent damage. Is there anyway at all to have both cards running while getting decent performance and not sacrificing the ability to use vulkan?

You’ll have to use PRIME output then:
https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910
Which distribution are you running?
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

I am using arch linux with the 418.43 nvidia driver. I will check out the link and see if I can get it working.

I followed the link and it gave me another link to here: http://us.download.nvidia.com/XFree86/Linux-x86/319.12/README/randr14.html
I turned off bumblebee and I changed my xorg.conf to look like this:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia" 0 0
    Inactive "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "1:0:0"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    # Uncomment this line if your computer has no display devices connected to
    # the NVIDIA GPU.  Leave it commented if you have display devices
    # connected to the NVIDIA GPU that you would like to use.
    #Option "UseDisplayDevice" "none"
    Option "AllowEmptyInitialConfiguration"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "0:2:0"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Unfortunately all it does is give me a blank screen.

You probably missed the second step, setting your display-manager to run the necessary xrandr commands on start:
https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Display_Managers

I actually did that as well and still got a blank screen.