Unable to install CUDA Toolkit Windows 7 64-bit


I’m facing problems when trying to install CUDA Toolkit on my 64-bit Windows 7, with NVIDIA GeForce GT 330 on board. What I’ve tried to do was:

  1. Downloading Dev Drivers and CUDA Toolkit from here: http://developer.nvidia.com/cuda-toolkit-40 - proper (64-bit Win 7) versions, though I’ve also tried 32-bit ones.

  2. Installing Dev Drivers (successfully)

After doing this I should be able to install CUDA Toolkit, according to “CUDA Getting Started” guide. Unfortunately, when trying to run *.msi installer, I get following error:

(note that’s just translation of an original error)

Other MSI files are executed without problem. I’ve also tried all solutions of MSI problems I could find on google. I even reinstalled my Windows… all in vain, i still get the same error.

I’m pretty stuck with this, any kind of help would be greatly appreciated.

Kind regards,


Problem solved, seems like some firewall (windows or hardware, not sure) messed up the download. All MSIs worked fine when downloaded using another PC in another network.