Unable to install libg2o using nvdia docker container

Hello Every One,

I am trying to install lib2o on top of below docker container instead of using Base ros:galactic image.

Actually, i am planning to run Openvslam application from below.openvslam_ros/Dockerfile.socket at fdbd287d80a3a5cc4ac1a143dc937adb4697b120 · OpenVSLAM-Community/openvslam_ros · GitHub

but unfortunately, i have been getting error as: unable to locate package libg2o.

I tried to edit above nvdia docker container at line 116 with below:
libg2o.

End task: combine both ros as well as non ros version of openvslam in a single container. But still got error as below: (error occurred between line 350 to 356 in attached dockerfile. )
/opt/ros/galactic/install/share/libg2o/local_setup.bash

I may sound very silly and may have messed up with the dockerfile. I am attaching my dockerfile for reference.

If a use ros:galactic as base image(official openvslam ros docker) then the docker build is through

Could you please help.

Thanks.

Hi,

libg2o is ROS library so you will need a ROS base rather than l4t-base:r32.5.0.
May I know why you want to use l4t-base:r32.5.0?

Thanks.

Hello,
Thanks for your reply.

My hardware is jetson agx xavier with jetpack as 4.5.1.
Shall i use any other nvidia base in that case?
Thanks.

Can i use l4t-base:r32.5.0-pth1.7-py3 ??

Hi,

The Dockerfile you shared above should work with JetPack 4.5.1.
Have you modified the file? If yes, could you try the default version first?

Thanks.

Yes, I tried the default dockerfile, it runs in my jetson but unfortunately libg2o is not available in this case.

Thanks for the confirmation.

We are checking this internally.
Will share more information with you later.

Hi,

We test the dockerfile on JetPack4.6.
It can build without an error related to libg2o.

Do you meet an error or just a warning?
Could you share the building log with us as well?

Thanks.

Hello,

I had used multistage builds in my dockerfile. I think that was the issue.
I removed multistage build and the error was gone. Thank you so much for your time and support.

Thanks

Thanks for the feedback.
Good to know it works now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.