Unable to install Vulkan Beta Drivers

I was trying to preview some of the new functionalities introduced in the Vulkan Beta Driver found here: https://developer.nvidia.com/vulkan-driver on a Windows 10 Pro 1903 laptop using a GTX 1660 Ti card but it is impossible for me to install those drivers because they complain about the version of Windows not being compatible.

Thing is, I have the DCH drivers installed, and seem to have no way to install the standard drivers (I tried to uninstall them with DDU, to uninstall them from Windows device manager, etc, nothing worked), but neither standard, nor the DCH version of the Vulkan Beta Drivers want to install.

I managed to install them (426.06) by modifiyng the .inf because appearently my gpu wasn’t among the supported ones (DEV_2191, SUBSYS_3FFC17AA) for some reason, BUT it turns out that the VK_NV_ray_tracing extension is missing, whereas it is present on 431.60.