Unable to see menu bar and top bar on nvidia linux

I first flashed the OS on jetson tx2 and after that i installed all the jetpack 3.1 components like cuda,tensorrt, etc. After the successful installation the screen was properly showing the menu bar and top bar but after switching off & then i switched on the jetson after 2 hours i was unable to see the menu bar and top bar, only desktop icons are being shown and also ctrl-alt-t is not working. I have connected jetson to a monitor using hdmi to vga connector previously and also currently after installation of jetpack. But i am not facing this issue with ubuntu user on same monitor. Can someone please help me. I have used different monitor also but same issue on all for nvidia user & not for ubuntu user

VGA is not supported. The reason for this is that VGA cuts a wire used for the video card doing a query to the monitor to ask the monitor what its specs are. Without this you would need an old style “driver disk” to enter specs into a database and then manually select the monitor. Your video mode is a default and seeing anything means you got lucky the monitor has some function at that setting.

I would bet that the desktop is larger than the screen and it is working, but the top is cut off. Were both monitors using the VGA adapter?

You may also want to check disk space to see if it filled up (“df -H -t ext4”, e.g., over ssh connection if you can’t do this directly from the Jetson). Lack of disk space can cause peculiar problems. You might also want to check if “sudo ls /” works as expected…I’m curious if the sudo command itself is working.

Note that there is some software which needs to be in group “video” and a user with that group can access GPU functionality, while a user not in that group cannot (at least not some of the GPU). Normally users “ubuntu” and “nvidia” are already in that group, so I would not expect this to be why “ubuntu” and “nvidia” differ…but the idea behind this may still be relevant to why the two users have a different behavior under the same circumstances. File access could differ (and this includes previously cached files, not just permanent files). Until the VGA adapter is gone and you know there is disk space available I’m not sure any other tests will be particularly helpful.

Hi linuxdev, thanks for the quick reply. Sorry for the late response as we were unable to find a hdmi monitor. But today i tested on hdmi monitor and the same issue occurred and ubuntu user is working fine. Also i have checked all the thing which u said like checking the memory space and that also has free memory available. So i am not getting what is the issue with the nvidia user. Should i flash the OS again? Or any another way i can solve this issue.

If it is a permission issue a flash might help. Keep in mind that if in the original flash the sample rootfs was unpacked without sudo, or if it was unpacked onto a non-Linux file system type (such as VFAT or NTFS on a USB key), then the same thing would happen again unless fixed. You’ll want to be sure your host is set up correctly before starting.

Are you command line flashing, or are you using JetPack? Is there anything unusual about the host, e.g., a VM or using a USB key for the hard disk? Which Linux distribution/version is your host?

Thanks for the prompt reply!! I am using jetpack to flash the os on jetson and the host is a dual booted windows + ubuntu laptop and the ubuntu version is 16.04 lts. And the host was setup properly and the os was flashed successfully(atleast the message showed that) and also it was flashed without sudo!

It is not needed to use sudo for jetpack3.1. Please also take a photo for this error.

“After the successful installation the screen was properly showing the menu bar and top bar but after switching off & then i switched on the jetson after 2 hours i was unable to see the menu bar and top bar, only desktop icons are being shown and also ctrl-alt-t is not working.”

Does screen saver work and it becomes blanked during this period?

I added a comment here on a known Ubuntu bug for the menu bar…which may apply to this:
https://devtalk.nvidia.com/default/topic/1030157/desktop-gui-not-loading-properly/?offset=4#5240981

I am thinking perhaps this same fix would apply in your case.

This is what we get on the 2 user accounts:
nvidia:

ubuntu:

we tried the commands given on the link, but the top bar comes for about a second and then again vanishes
and also the terminal says that it is already using unity

Since this does not happen to me it is hard to reproduce. It does seem this is the right path though since it causes momentary success. What I am thinking is if perhaps you save a copy of “~/.config/compiz-1/compizconfig/” such that we could see all file permissions and sizes, and then let it recreate those files and compare permissions and checksums. For example, while not logged in to the GUI:

dconf reset -f /org/compiz/
setsid unity
mv ~/.config/compiz-1/compizconfig untouched_compiz_config
# Now log in to GUI, wait for this to be an issue, then log out.
mv ~/.config/compiz-1/compizconfig failed_compiz_config

Next, display permissions side by side…generate these lists of permissions (assumes you are in the directory where you moved “untouched” and “failed”:

ls -l `find . -type f ./untouched_compiz_config` 2>&1 | tee untouched_perms.txt
ls -l `find . -type f ./failed_compiz_config` 2>&1 | tee failed_perms.txt
sha1sum `find . -type f ./untouched_compiz_config` 2>&1 | tee untouched_checksum.txt
sha1sum `find . -type f ./failed_compiz_config` 2>&1 | tee failed_checksum.txt

The purpose of this is to see what is changing when a freshly set config begins failing.

yashranka999,

Any quick way to reproduce this issue?

I am facing the same problem after installing the jetpack 3.1, any suggestion?

Could you try to close session and open as other nvidia/ubuntu user ?
Once I’ve seen something similar and it went ok after doing that.

Still not working,in the ubuntu session the menu bar is displayed and working

You may try to shutdown from ubuntu user (where it works) and reboot.
I agree this looks a bit esoteric, but this is what I did.

if you reinstall it somehow it might restore

sudo apt-get install --reinstall ubuntu-desktop

i’ve tried reinstall ubuntu-desktop and reboot from ubuntu session and still not working, someting i found is that when open a new terminal it’s like is fixed in that position the samme happen with chromium and any directory

If you have serial console then you might want to monitor boot, and then “dmesg --follow” while logging in…there may be a clue.

Similarly, the “/var/log/Xorg.0.log” may have a clue.

Faced this issue today on my TX1, ubuntu session had screen locked for a few hours before.
I had upgraded ubuntu yesterday, but shutdown normally later and booted fine this morning.

The following command seems to have fixed it (only user ubuntu was affected) :

sudo rm -r /home/ubuntu/.cache/compizconfig-1

Thanks a lot that fixed my problem