Unable to to install Nvidia Driver on Drive AGX Orin

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)

Target Operating System
[*] Linux

Hardware Platform
[*] DRIVE AGX Orin Developer Kit (940-63710-0010-300)
DRIVE AGX Orin Developer Kit (940-63710-0010-200)
DRIVE AGX Orin Developer Kit (940-63710-0010-100)
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)

SDK Manager Version
[*] other

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
[*] native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers

I have been following this link to install Nvidia GPU Driver: NVIDIA Driver Installation Quickstart Guide :: NVIDIA Tesla Documentation

I then went to this link: CUDA Installation Guide for Linux

Followed the Native installation for Cuda toolkit as shown in the screenshots below:

As seen in the screenshot I selected Deb(local)

I run the below code to install the cuda toolkit which worked

"wget https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/sbsa/cuda-ubuntu2004.pin

sudo mv cuda-ubuntu2004.pin /etc/apt/preferences.d/cuda-repository-pin-600

wget https://developer.download.nvidia.com/compute/cuda/12.3.1/local_installers/cuda-repo-ubuntu2004-12-3-local_12.3.1-545.23.08-1_arm64.deb

sudo dpkg -i cuda-repo-ubuntu2004-12-3-local_12.3.1-545.23.08-1_arm64.deb

sudo cp /var/cuda-repo-ubuntu2004-12-3-local/cuda-*-keyring.gpg /usr/share/keyrings/

sudo apt-get update

sudo apt-get -y install cuda-toolkit-12-3"

However when I ran the code for Nvidia Driver installer (Legacy kernel module flavor) as shown in the screenshot below it did not work at the terminal

here are the screenshots from the terminal:

How do I fix the following errors:

Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)



Dear @kevin.kal,
DRIVE OS installs the supported CUDA toolkit and NVIDIA drivers on target. May I know why you want to uninstall them?

I wasn’t uninstalling them… I was trying to install them… I have been trying follow the manuals as listed on the links.

Dear @kevin.kal,
You need to use CUDA toolkit and drivers that comes with DRIVE OS. You can not install CUDA seperately on DRIVE platform.

I have now re-flashed Drive AGX Orin - I had some errors I couldn’t fix.

Could you please tell him how to check if the DRIVE OS has CUDA Toolkit already installed?

Dear @kevin.kal,
As you selected, I am assuming you are using docker container to flash the target. As mentioned earlier, CUDA toolkit/drivers is part of DRIVEOS, if the flashing is successful, they get installed and can be seen in flashing logs on target. Could you share the flashing error logs?

sure I have attend the flash log from host pc
log_8w1v3f4zusjr7y96dplnba2cgh0qxoem.txt (2.1 KB)

Dear @kevin.kal,
I see in the log, the flashing is successful. So, the needed CUDA toolkit /drivers are installed on target already. As clarified earlier, you can not install CUDA toolkit/ driver other than what comes with DRIVE OS image.

Okay No problem thanks for clarifying… I am still not able to get started with Nvidia Drive SDK NGC Docker Container. I am at the section where it says “Getting Started with the Nvidia DriveWorks SDK”

I’ve chosen the NGC Docker Container Section

here is the link:


I am trying to start the Guest Docker container on Host PC but I am getting the following errors shows on screenshot

Could you please let me know how to solve this issue?


Dear @kevin.kal,
May I know if sudo docker run -it --privileged --net=host -v /dev/bus/usb:/dev/bus/usb -v /drive_flashing:/drive_flashing nvcr.io/drive/driveos-sdk/drive-agx-orin-linux-aarch64-sdk-build-x86:latest is working and you are able to access docker container?
Do you plan to compile the DW samples on docker?

Yes this code worked for me and I was able to flash using docker container and yes I plan to compile and run DW samples on docker. I am trying to follow the tutorials section to understand what Nvidia Drive AGX Orin can do.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.