Unknown or not supported format: 808669784

When i run

QT_QPA_PLATFORM=wayland dbus-run-session kwin_wayland --xwayland “plasmashell -p org.kde.plasma.mobileshell”

I get following error

src/gbm\_drv\_common.c:130: GBM-DRV error (get\_bytes\_per\_component): Unknown or not supported format: 808669784

src/gbm\_drv\_common.c:130: GBM-DRV error (get\_bytes\_per\_component): Unknown or not supported format: 808669784

From Kwin developer

DRM_FORMAT_XRGB2101010

Version : 550.54.14
Kwin version : 6.0.2

My nixos version nixos/flake.lock at 3c78f3a2c12762dd87f082e386e53cdbc44d857e · mrdev023/nixos · GitHub

And nvidia conf

{ config, pkgs, ... }:

{
  # Enable OpenGL
  hardware.opengl = {
    enable = true;
    driSupport = true;
    driSupport32Bit = true;
  };

  # Load nvidia driver for Xorg and Wayland
  services.xserver.videoDrivers = ["nvidia"];

  hardware.nvidia = {
    # Modesetting is required.
    modesetting.enable = true;

    # Nvidia power management. Experimental, and can cause sleep/suspend to fail.
    powerManagement.enable = false;
    # Fine-grained power management. Turns off GPU when not in use.
    # Experimental and only works on modern Nvidia GPUs (Turing or newer).
    powerManagement.finegrained = false;

    # Use the NVidia open source kernel module (not to be confused with the
    # independent third-party "nouveau" open source driver).
    # Support is limited to the Turing and later architectures. Full list of 
    # supported GPUs is at: 
    # https://github.com/NVIDIA/open-gpu-kernel-modules#compatible-gpus 
    # Only available from driver 515.43.04+
    # Currently alpha-quality/buggy, so false is currently the recommended setting.
    open = false;

    # Enable the Nvidia settings menu,
	  # accessible via `nvidia-settings`.
    nvidiaSettings = true;

    # Optionally, you may need to select the appropriate driver version for your specific GPU.
    package = config.boot.kernelPackages.nvidiaPackages.latest;
  };
}

It’s implemented in kwin src/utils/drm_format_helper.cpp · v6.0.2 · Plasma / KWin · GitLab

So i think it’s not a bug kwin side

Persist on nvidia 550.67

485496 – Can't run kwin plasma mobile with nvidia (Sub wayland session for dev) Issue from me

Seem to be a kwin issue

Is fixed with backends/wayland: Check whether it's possible to create a swapchain with the given format+modifier (!5745) · Merge requests · Plasma / KWin · GitLab

Kwin issue 485496 – Can't run kwin plasma mobile with nvidia (Sub wayland session for dev)