Upgrading DGX OS on a DGX Station

Hi folks, I’m facing issues trying to upgrade the DGX OS from 3.1.8 to 4+. When I try to run sudo dgx-release-upgrade it tells me

Please install all available updates for your release before upgrading

The thing is, I have already done sudo apt update and sudo apt -y full-upgrade. I do see some issues like

Some help on this would be great! Thanks a lot.

Hi there,

It looks like there are problems with some of your 3rd party repos. Can you please resolve these issues first:
• “cloud.r-project.org” – GPG key expired
• “cloud.monetdb.org” – replace “suite” with the actual distro you’re on, i.e. “lsb_release -cs”

Hi!
I resolved the monetdb.org by replacing it with xenial.

As for the cloud.r-project.org, I’m not sure how to replace the GPG key. I’ve tried other methods on stackoverflow but it doesn’t seem to get replaced. I suspect it’s because it looks like I have a duplicate key. Here’s my apt-key, I’m not sure what to do if there’s a clash of key IDs

Based on my quick skim thru the R website [1][2], I’d suggest the following to delete the duplicate key:
gpg -delete-key "Totally Legit Signing Key"

Please also see the “Secure APT” section [3]

[1] UBUNTU PACKAGES FOR R
[2] Changes to CRAN Ubuntu webpage regarding apt-secure key · R Ubuntu Blog
[3] UBUNTU PACKAGES FOR R

Yup, I’ve done that. Seems like it works now! Though I’m looking at the DGX OS upgrade, it seems to be removing nvidia-docker, has that been deprecated? If it has been, what’s the replacement or where can I find the documentation?

Yes, nvidia-docker, which was a wrapper to the docker CLI, has been deprecated starting in the DGX OS 4 releases [1]

It was replaced by the nvidia-container-runtime [2][3]

[1] DGX OS Desktop Software Release Notes :: DGX Systems Documentation
[2] Upgrading to the NVIDIA Container Runtime for Docker :: DGX Systems Documentation
[3] GitHub - NVIDIA/nvidia-container-runtime: NVIDIA container runtime