Upgrading L4T from 32.5.0 to 32.5.2: ERROR. Procedure for bl_update_payload update FAILED

I have a Jetson Xavier AGX and tried to upgrade the L4T to a new point release following the instructions found here:
Over-the-Air Update

after issuing the command 'sudo apt upgrade’ I got the following:

Setting up libgstreamer-plugins-base1.0-0:arm64 (1.14.5-0ubuntu1~18.04.3) …
Setting up nvidia-l4t-kernel-dtbs (4.9.201-tegra-32.5.2-20210709090156) …
Setting up libpython3.6-stdlib:arm64 (3.6.9-1~18.04ubuntu1.4) …
Setting up nvidia-l4t-bootloader (32.5.2-20210709090156) …
Warning: Cannot get compatible board name.
2888-400-0004–1-2-rtso-1001-mmcblk0p1
Starting bootloader post-install procedure.
rootfs AB is not enabled.
ERROR. Procedure for bl_update_payload update FAILED.
Cannot install package. Exiting…
dpkg: error processing package nvidia-l4t-bootloader (–configure):
installed nvidia-l4t-bootloader package post-installation script subprocess returned error exit status 1
Setting up chromium-browser (95.0.4638.69-0ubuntu0.18.04.1) …
Setting up gstreamer1.0-plugins-base:arm64 (1.14.5-0ubuntu1~18.04.3) …
Setting up nvidia-l4t-xusb-firmware (32.5.2-20210709090156) …
Warning: Cannot get compatible board name.
2888-400-0004–1-2-rtso-1001-mmcblk0p1
Starting xusb firmware post-install procedure.
Update xusb firmware completed.
Reboot the target system for changes to take effect.
Setting up libqt5widgets5:arm64 (5.9.5+dfsg-0ubuntu2.6) …

setting up continues with a few more packages and finally I get:

Processing triggers for ca-certificates (20210119~18.04.2) …
Updating certificates in /etc/ssl/certs…
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d…
done.
Processing triggers for initramfs-tools (0.130ubuntu3.13) …
update-initramfs: Generating /boot/initrd.img-4.9.201-tegra
Warning: couldn’t identify filesystem type for fsck hook, ignoring.
I: The initramfs will attempt to resume from /dev/zram3
I: (UUID=26284415-91dd-4035-86c6-e0b851cdb92f)
I: Set the RESUME variable to override this.
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/aarch64-linux-gnu_EGL.conf: No such file or directory
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/aarch64-linux-gnu_GL.conf: No such file or directory
Processing triggers for nvidia-l4t-kernel (4.9.201-tegra-32.5.2-20210709090156) …
Processing triggers for libc-bin (2.27-3ubuntu1.4) …
Errors were encountered while processing:
nvidia-l4t-bootloader
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried rebooting and then 'sudo apt upgrade’ once more, but issue remains.

I intent to use the board in a production environment, but now I’m stuck as I don’t know if the installation is corrupted or not.

I tried searching the forums for similar issues, but couldn’t find anything that could help me resolve the issue. Can anyone please advise?

hello gbetsos,

there’s the failure that cannot get compatible board names.
could you please share the TNSPEC, i.e. $ cat /etc/nv_boot_control.conf
thanks

This is the file:

TNSPEC 2888-400-0004-G.0-1-2-rtso-1001-mmcblk0p1
COMPATIBLE_SPEC 2888-400-0004–1-2-rtso-1001-mmcblk0p1
TEGRA_CHIPID 0x19
TEGRA_OTA_BOOT_DEVICE /dev/mmcblk0boot0
TEGRA_OTA_GPT_DEVICE /dev/mmcblk0boot1

I think the problem is in the name, 2888-400-0004-G.0-1-2-rtso-1001-mmcblk0p1, right? There is a warning message about it,

Warning: Cannot get compatible board name.

My real problem is that I intend to install an nvme disk on the board and make it boot L4T from the disk. Is it probable that the nvidia-l4t-bootloader package issue will cause any problems down the road?

hello gbetsos,

it’s not Jetson AGX Xavier DevKit, right?
please refer to l4t_generate_soc_bup.sh for t19x_spec, you should include the board names into the spec then running the BUP installation again,
thanks

Hi,

right, it’s not the devkit, it’s a custom carrier board.

Can you please tell me where can I find l4t_generate_soc_bup.sh?

Also, I’m completely ignorant of the process of running BUP installation. Does this mean I will need to flash the emmc again?

hello gbetsos,

if you install the JetPack SDK | NVIDIA Developer, it’ll also download the release image and also other necessary tools, scripts.
the default installation path looks like this… ~/nvidia/nvidia_sdk/JetPack_<version>_<platform>/Linux_for_Tegra/

If you are using custom carrier board, in most case, you cannot use deb packages from NVIDIA anymore.

Make it easier to understand, “apt upgrade” will make you try to update from old release to latest release.
However, it is not possible for such service to know your customization like dtb or bootloader. The deb package is just for devkit.

Thus, if you are the vendor to provide such carrier board, you should create your own debian package based on new release and set up your own apt server for your client.

But if you are the client that bought a custom board from some vendors, then you should ask your vendor how to update from old release to new release.