USB is not recognized

I designed the JETSON TX2 carrier board with power monitoring function. Its pin definition is the same as the official motherboard, but USB is not recognized. What could be the cause?

Hi, if sw is same, it looks more like a hw design problem. There is a checklist table in OEM DG which you can use to compare to your design to find out difference if have.

t is confirmed that the USB pin connection is consistent, but the USB is always abnormal. And USB_VBUS_EN1 (A18) has not been output. What conditions does the USB output need to meet? USB_VBUS_EN1 (A18) is also output normally on the official development board, and the USB can be used normally

USB_VBUS_EN0 (A17)、USB_VBUS_EN1 (A18) no output from both, always low, what could be the reason?

Is there any peripheral circuit required for USB boot? What conditions are needed?

Is it possible that there is a problem with the power monitoring circuit, how do I need to confirm whether the power is normal?

[0000.296] I> Welcome to MB2(TBoot-BPMP)(version: 01.00.160913-t186-M-00.00-mobile-1b8ce67c)
[0000.304] I> bit @ 0xd480000
[0000.307] I> Boot-device: eMMC
[0000.311] I> sdmmc bdev is already initialized
[0000.316] I> pmic: reset reason (nverc) : 0x80
[0000.323] I> Found 16 partitions in SDMMC_BOOT (instance 3)
[0000.330] I> Found 31 partitions in SDMMC_USER (instance 3)
[0000.336] I> A/B: bin_type (16) slot 0
[0000.340] I> Loading partition bpmp-fw at 0xd7800000
[0000.344] I> Reading two headers - addr:0xd7800000 blocks:1
[0000.350] I> Addr: 0xd7800000, start-block: 58777608, num_blocks: 1
[0000.365] I> Binary(16) of size 533504 is loaded @ 0xd7800000
[0000.370] I> A/B: bin_type (17) slot 0
[0000.374] I> Loading partition bpmp-fw-dtb at 0xd79f0000
[0000.379] I> Reading two headers - addr:0xd79f0000 blocks:1
[0000.385] I> Addr: 0xd79f0000, start-block: 58780024, num_blocks: 1
[0000.400] I> Binary(17) of size 465840 is loaded @ 0xd798e200
[0000.579] I> Loading SCE-FW …
[0000.582] I> A/B: bin_type (12) slot 0
[0000.586] I> Loading partition sce-fw at 0xd7300000
[0000.590] I> Reading two headers - addr:0xd7300000 blocks:1
[0000.596] I> Addr: 0xd7300000, start-block: 58782024, num_blocks: 1
[0000.606] I> Binary(12) of size 125168 is loaded @ 0xd7300000
[0000.612] I> Init SCE
[0000.614] I> Loading APE-FW …
[0000.617] I> A/B: bin_type (11) slot 0
[0000.621] I> Loading partition adsp-fw at 0xd7400000
[0000.626] I> Reading two headers - addr:0xd7400000 blocks:1
[0000.631] I> Addr: 0xd7400000, start-block: 58761224, num_blocks: 1
[0000.641] I> Binary(11) of size 107808 is loaded @ 0xd7400000
[0000.647] I> Copy BTCM section
[0000.650] I> A/B: bin_type (13) slot 0
[0000.654] I> Loading partition cpu-bootloader at 0x96000000
[0000.659] I> Reading two headers - addr:0x96000000 blocks:1
[0000.665] I> Addr: 0x96000000, start-block: 58740744, num_blocks: 1
[0000.677] I> Binary(13) of size 277776 is loaded @ 0x96000000
[0000.683] I> A/B: bin_type (20) slot 0
[0000.686] I> Loading partition bootloader-dtb at 0x8520f400
[0000.692] I> Reading two headers - addr:0x8520f400 blocks:1
[0000.697] I> Addr: 0x8520f400, start-block: 58742792, num_blocks: 1
[0000.712] I> Binary(20) of size 342752 is loaded @ 0x8520f400
[0000.718] I> A/B: bin_type (14) slot 0
[0000.722] I> Loading partition secure-os at 0x8530f600
[0000.727] I> Reading two headers - addr:0x8530f600 blocks:1
[0000.732] I> Addr: 0x8530f600, start-block: 58744840, num_blocks: 1
[0000.745] I> Binary(14) of size 312752 is loaded @ 0x8530f600
[0000.753] I> TOS boot-params @ 0x85000000
[0000.757] I> TOS params prepared
[0000.760] I> Loading EKS …
[0000.762] I> A/B: bin_type (15) slot 0
[0000.766] I> Loading partition eks at 0x8590f800
[0000.771] I> Reading two headers - addr:0x8590f800 blocks:1
[0000.776] I> Addr: 0x8590f800, start-block: 58757128, num_blocks: 1
[0000.784] I> Binary(15) of size 1040 is loaded @ 0x8590f800
[0000.790] I> EKB detected (length: 0x400) @ 0x8590f800
[0000.795] I> Copied encrypted keys
[0000.799] I> boot profiler @ 0x275844000
[0000.802] I> boot profiler for TOS @ 0x275844000
[0000.807] I> Unhalting SCE
[0000.810] I> Primary Memory Start:80000000 Size:70000000
[0000.815] I> Extended Memory Start:f0110000 Size:1856f0000
[0000.822] I> MB2(TBoot-BPMP) done

NOTICE: BL31: v1.3(release):a28d87f09
NOTICE: BL31: Built : 21:15:42, Aug 12 2019
ipc-unittest-main: 1519: Welcome to IPC unittest!!!
ipc-unittest-main: 1531: waiting forever
ipc-unittest-srv: 329: Init unittest services!!!
keystore-demo: 141: Hello world from keystore-demo app
keystore-demo: 207: main: EKB contents match expected value
exit called, thread 0xffffffffea87ad58, name trusty_app_2_7d18fc60-e9fc-11e8
platform_bootstrap_epilog: trusty bootstrap complete
[0001.182] I> Welcome to Cboot
[0001.185] I> Cboot Version: t186-dcb303f9
[0001.188] I> CPU-BL Params @ 0x275800000
[0001.192] I> 0) Base:0x00000000 Size:0x00000000
[0001.197] I> 1) Base:0x277f00000 Size:0x00100000
[0001.201] I> 2) Base:0x277e00000 Size:0x00100000
[0001.206] I> 3) Base:0x277d00000 Size:0x00100000
[0001.210] I> 4) Base:0x277c00000 Size:0x00100000
[0001.215] I> 5) Base:0x277b00000 Size:0x00100000
[0001.219] I> 6) Base:0x277800000 Size:0x00200000
[0001.224] I> 7) Base:0x277400000 Size:0x00400000
[0001.228] I> 8) Base:0x277a00000 Size:0x00100000
[0001.233] I> 9) Base:0x277300000 Size:0x00100000
[0001.237] I> 10) Base:0x276800000 Size:0x00800000
[0001.242] I> 11) Base:0x30000000 Size:0x00040000
[0001.246] I> 12) Base:0xf0000000 Size:0x00100000
[0001.251] I> 13) Base:0x30040000 Size:0x00001000
[0001.255] I> 14) Base:0x30048000 Size:0x00001000
[0001.259] I> 15) Base:0x30049000 Size:0x00001000
[0001.264] I> 16) Base:0x3004a000 Size:0x00001000
[0001.268] I> 17) Base:0x3004b000 Size:0x00001000
[0001.273] I> 18) Base:0x3004c000 Size:0x00001000
[0001.277] I> 19) Base:0x3004d000 Size:0x00001000
[0001.282] I> 20) Base:0x3004e000 Size:0x00001000
[0001.286] I> 21) Base:0x3004f000 Size:0x00001000
[0001.290] I> 22) Base:0x00000000 Size:0x00000000
[0001.295] I> 23) Base:0xf0100000 Size:0x00010000
[0001.299] I> 24) Base:0x00000000 Size:0x00000000
[0001.304] I> 25) Base:0x00000000 Size:0x00000000
[0001.308] I> 26) Base:0x00000000 Size:0x00000000
[0001.313] I> 27) Base:0x00000000 Size:0x00000000
[0001.317] I> 28) Base:0x84400000 Size:0x00400000
[0001.321] I> 29) Base:0x30000000 Size:0x00010000
[0001.326] I> 30) Base:0x278000000 Size:0x08000000
[0001.330] I> 31) Base:0x00000000 Size:0x00000000
[0001.335] I> 32) Base:0x276000000 Size:0x00600000
[0001.339] I> 33) Base:0x80000000 Size:0x70000000
[0001.344] I> 34) Base:0xf0110000 Size:0x1856f0000
[0001.348] I> 35) Base:0x00000000 Size:0x00000000
[0001.353] I> 36) Base:0x00000000 Size:0x00000000
[0001.357] I> 37) Base:0x2772e0000 Size:0x00020000
[0001.362] I> 38) Base:0x84000000 Size:0x00400000
[0001.366] I> 39) Base:0x96000000 Size:0x02000000
[0001.371] I> 40) Base:0x85000000 Size:0x01200000
[0001.375] I> 41) Base:0x275800000 Size:0x00500000
[0001.380] I> 42) Base:0x00000000 Size:0x00000000
[0001.384] I> 43) Base:0x00000000 Size:0x00000000
[0001.388] GIC-SPI Target CPU: 4

[0001.392] Interrupts Init done

[0001.395] calling constructors

[0001.398] initializing heap
[0001.401] initializing threads

[0001.404] initializing timers

[0001.407] creating bootstrap completion thread

[0001.412] top of bootstrap2()

[0001.415] CPU: ARM Cortex A57

[0001.418] CPU: MIDR: 0x411FD073, MPIDR: 0x80000100

[0001.423] initializing platform

[0001.426] I> Boot-device: eMMC
[0001.431] I> sdmmc bdev is already initialized
[0001.437] I> Found 16 partitions in SDMMC_BOOT (instance 3)
[0001.446] I> Found 31 partitions in SDMMC_USER (instance 3)
[0001.452] W> opt-in fuse is not set, skip fuse_burning
[0001.457] I> Reserved memory at 0xfbe00000 for U-Boot relocation
[0001.462] W> No valid slot number is found in scratch register
[0001.468] W> Return default slot: _a
[0001.472] I> A/B: bin_type (21) slot 0
[0001.475] I> Loading partition kernel-dtb at 0x80000000 from device(0x1)
[0001.489] I> Kernel_dtb @0x80000000
[0001.493] I> Bl_dtb @0x8520f400
[0001.496] I> gpio framework initialized
[0001.502] I> tegrabl_gpio_driver_register: register ‘nvidia,tegra186-gpio’ driver
[0001.512] I> tegrabl_gpio_driver_register: register ‘nvidia,tegra186-gpio-aon’ driver
[0001.519] I> tegrabl_tca9539_init: i2c bus: 0, slave addr: 0xee
[0001.528] E> I2C: slave not found in slaves.
[0001.532] E> I2C: Could not write 0 bytes to slave: 0x00ee with repeat start false.
[0001.539] E> I2C_DEV: Failed to send register address 0x00000004.
[0001.545] E> I2C_DEV: Could not write 1 registers of size 1 to slave 0xee at 0x00000004 via instance 0.
[0001.555] E> tca9539_device_init: failed to write polar reg
[0001.560] E> tegrabl_tca9539_init: failed to init device!
[0001.565] I> tegrabl_tca9539_init: i2c bus: 0, slave addr: 0xe8
[0001.572] E> I2C: slave not found in slaves.
[0001.576] E> I2C: Could not write 0 bytes to slave: 0x00e8 with repeat start false.
[0001.584] E> I2C_DEV: Failed to send register address 0x00000004.
[0001.590] E> I2C_DEV: Could not write 1 registers of size 1 to slave 0xe8 at 0x00000004 via instance 0.
[0001.599] E> tca9539_device_init: failed to write polar reg
[0001.604] E> tegrabl_tca9539_init: failed to init device!
[0001.612] I> fixed regulator driver initialized
[0001.644] I> register ‘maxim’ power off handle
[0001.650] I> virtual i2c enabled
[0001.653] I> registered ‘maxim,max77620’ pmic
[0001.657] I> tegrabl_gpio_driver_register: register ‘max77620-gpio’ driver
[0001.670] I> Find /i2c@c250000’s alias i2c7
[0001.674] I> Reading eeprom i2c=7 address=0x50
[0001.703] I> Device at /i2c@c250000:0x50
[0001.707] I> Reading eeprom i2c=7 address=0x57
[0001.711] E> I2C: slave not found in slaves.
[0001.715] E> I2C: Could not write 0 bytes to slave: 0x00ae with repeat start true.
[0001.723] E> I2C_DEV: Failed to send register address 0x00000000.
[0001.729] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xae at 0x00000000 via instance 7.
[0001.738] E> eeprom: Failed to read I2C slave device
[0001.743] I> Eeprom read failed 0x3526070d
[0001.748] I> Find /i2c@c240000’s alias i2c1
[0001.752] I> Reading eeprom i2c=1 address=0x51
[0001.757] E> I2C: slave not found in slaves.
[0001.761] E> I2C: Could not write 0 bytes to slave: 0x00a2 with repeat start true.
[0001.769] E> I2C_DEV: Failed to send register address 0x00000000.
[0001.775] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xa2 at 0x00000000 via instance 1.
[0001.784] E> eeprom: Retry to read I2C slave device.
[0001.789] E> I2C: slave not found in slaves.
[0001.793] E> I2C: Could not write 0 bytes to slave: 0x00a2 with repeat start true.
[0001.801] E> I2C_DEV: Failed to send register address 0x00000000.
[0001.807] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xa2 at 0x00000000 via instance 1.
[0001.816] E> eeprom: Failed to read I2C slave device
[0001.821] I> Eeprom read failed 0x3526070d
[0001.825] I> Find /i2c@3160000’s alias i2c0
[0001.829] I> Reading eeprom i2c=0 address=0x50
[0001.834] E> I2C: slave not found in slaves.
[0001.838] E> I2C: Could not write 0 bytes to slave: 0x00a0 with repeat start true.
[0001.846] E> I2C_DEV: Failed to send register address 0x00000000.
[0001.852] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xa0 at 0x00000000 via instance 0.
[0001.861] E> eeprom: Failed to read I2C slave device
[0001.866] I> Eeprom read failed 0x3526070d
[0001.871] I> Find /i2c@3180000’s alias i2c2
[0001.875] I> Reading eeprom i2c=2 address=0x54
[0001.879] I> Enabling gpio chip_id = 2, gpio pin = 9
[0001.884] C> GPIO driver for chip_id 0x2 could not be found
[0001.889] E> cam_eeprom_read: Can’t get gpio driver
[0001.894] I> Eeprom read failed 0x4d4d000d
[0001.898] I> Reading eeprom i2c=2 address=0x57
[0001.902] I> Enabling gpio chip_id = 2, gpio pin = 9
[0001.907] C> GPIO driver for chip_id 0x2 could not be found
[0001.912] E> cam_eeprom_read: Can’t get gpio driver
[0001.917] I> Eeprom read failed 0x4d4d000d
[0001.921] I> create_pm_ids: id: 3310-1000-D00-F, len: 15
[0001.926] I> config: mem-type:00,power-config:00,misc-config:00,modem-config:00,touch-config:00,display-config:00, len: 93
[0001.958] I> enabling ‘vdd-hdmi’ regulator
[0001.962] E> tegrabl_display_get_pdata, failed to parse dtb settings
[0001.971] E> cannot find any other nvdisp nodes
[0001.975] E> no valid display unit config found in dtb
[0001.981] W> display init failed
[0001.984] initializing target

[0001.987] calling apps_init()

[0001.990] starting app kernel_boot_app

[0002.000] I> found decompressor handler: lz4-legacy
[0002.005] I> decompressing BMP blob …
[0002.015] I> Kernel type = Normal
[0002.018] I> Loading kernel from partition …
[0002.022] W> No valid slot number is found in scratch register
[0002.028] W> Return default slot: _a
[0002.031] I> A/B: bin_type (24) slot 0
[0002.041] I> Boot image size read from image header: f2d10
[0002.046] I> Boot image load address: 0x0x80400000
[0002.050] I> Loading partition kernel at 0x80400000 from device(0x1)
[0002.803] I> Kernel hdr @0x80400000
[0002.807] I> Kernel dtb @0x80000000
[0002.810] I> T18x: Authenticate boot.img (bin_type 24), max size 0x4000000
[0002.818] I> T18x: Authenticate tegra194-p2888-0001-p2822-0000.dtb (bin_type 21), max size 0x100000
[0002.827] I> Checking boot.img header magic … [0002.832] I> [OK]
[0002.833] I> Valid boot.img @ 0x80400000
[0002.837] I> decompressor handler not found
[0002.841] I> Copying kernel image (477378 bytes) from 0x80400800 to 0x80800000 … [0002.849] I> Done
[0002.850] I> Move ramdisk (len: 0) from 0x80475800 to 0x94830000
[0002.858] I> Updated bpmp info to DTB
[0002.863] I> Ramdisk: Base: 0x94830000; Size: 0x0
[0002.868] I> Updated initrd info to DTB
[0002.872] W> WARN: Fail to override “console=none” in commandline
[0002.877] E> tegrabl_linuxboot_add_disp_param, du 0 failed to get display params
[0002.885] E> tegrabl_linuxboot_add_disp_param, du 0 failed to get display params
[0002.892] E> tegrabl_linuxboot_add_disp_param, du 0 failed to get display params
[0002.899] I> disabled_core_mask: 0xffffff0c
[0002.903] W> No valid slot number is found in scratch register
[0002.909] W> Return default slot: _a
[0002.912] I> Active slot suffix:
[0002.915] I> add_boot_slot_suffix: slot_suffix =
[0002.920] I> Linux Cmdline: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 video=tegrafb no_console_suspend=1 earlycon=uart8250,mmio32,0x3100000 nvdumper_reserved=0x2772e0000 gpt usbcore.old_scheme_first=1 tegraid=18.1.2.0.0 maxcpus=6 boot.slot_suffix= boot.ratchetvalues=0.2031647.1 bl_prof_dataptr=0x10000@0x275840000 sdhci_tegra.en_boot_part_access=1
[0002.956] I> Updated bootarg info to DTB
[0002.960] I> eeprom_get_mac_addr: MAC (type: 0): 00:04:4b:de:4d:e6
[0002.966] I> eeprom_get_mac_addr: MAC (type: 1): 00:04:4b:de:4d:e7
[0002.972] I> eeprom_get_mac_addr: MAC (type: 2): 00:04:4b:de:4d:e8
[0002.980] E> Found no plugin manager ids in source DT
[0002.985] W> Add plugin manager ids from board info
[0002.990] E> “plugin-manager” doesn’t exist, creating
[0002.995] E> “ids” doesn’t exist, creating
[0002.999] E> “connection” doesn’t exist, creating
[0003.004] E> “configs” doesn’t exist, creating
[0003.008] I> create_pm_ids: id: 3310-1000-D00-F, len: 15
[0003.013] I> config: mem-type:00,power-config:00,misc-config:00,modem-config:00,touch-config:00,display-config:00, len: 93
[0003.024] I> Adding plugin-manager/ids/3310-1000-D00=/i2c@c250000:module@0x50
[0003.031] E> “i2c@c250000” doesn’t exist, creating
[0003.036] E> “module@0x50” doesn’t exist, creating
[0003.043] I> Adding plugin-manager/ids/3310-1000-D00-F
[0003.049] I> Adding plugin-manager/configs/3310-mem-type 00
[0003.055] I> Adding plugin-manager/configs/3310-power-config 00
[0003.061] I> Adding plugin-manager/configs/3310-misc-config 00
[0003.067] I> Adding plugin-manager/configs/3310-modem-config 00
[0003.073] I> Adding plugin-manager/configs/3310-touch-config 00
[0003.079] I> Adding plugin-manager/configs/3310-display-config 00
[0003.085] I> Adding plugin-manager/cvm
[0003.089] E> “chip-id” doesn’t exist, creating
[0003.093] I> Adding plugin-manager/chip-id/A02P
[0003.098] E> “odm-data” doesn’t exist, creating
[0003.102] I> Adding /chosen/plugin-manager/odm-data
[0003.112] I> added [base:0x80000000, size:0x70000000] to /memory
[0003.117] I> added [base:0xf0200000, size:0x185600000] to /memory
[0003.123] I> added [base:0x275e00000, size:0x200000] to /memory
[0003.129] I> added [base:0x276600000, size:0x200000] to /memory
[0003.135] I> added [base:0x277000000, size:0x200000] to /memory
[0003.141] I> Updated memory info to DTB
[0003.145] E> add_disp_param: failed to get display params for du=0
[0003.153] E> “reset” doesn’t exist, creating
[0003.157] E> “pmc-reset-reason” doesn’t exist, creating
[0003.163] E> “pmic-reset-reason” doesn’t exist, creating
[0003.169] I> Adding ecid(00000001645cc4000800000008fe84c0) to DT
[0003.175] I> disabled_core_mask: 0xffffff0c
[0003.187] I> Add serial number:1422119083365 as DT property
[0003.196] I> Plugin-manager override starting
[0003.201] I> node /plugin-manager/fragement@0 matches
[0003.212] I> node /plugin-manager/fragement@4 matches
[0003.224] I> node /plugin-manager/fragment-sdwake-p3310-1000-300 matches
[0003.242] I> node /plugin-manager/fragement-pmon-p3310-1000-300 matches
[0003.252] I> node /plugin-manager/fragement-pmon-p3310-1000-800 matches
[0003.261] I> node /plugin-manager/fragment-devslp@0 matches
[0003.278] I> node /plugin-manager/fragment-p3310-c00-comm matches
[0003.291] I> node /plugin-manager/fragment-p3310-c00-pmic matches
[0003.301] I> node /plugin-manager/fragment-p3310-c01 matches
[0003.313] I> node /plugin-manager/fragment-p3310-c03 matches
[0003.349] I> node /plugin-manager/fragment-p3310-c00-camera matches
[0003.374] I> Disable plugin-manager status in FDT
[0003.379] I> Plugin-manager override finished successfully
[0003.384] I> tegrabl_load_kernel_and_dtb: Done
[0003.388] E> tegrabl_display_clear: display is not initialized
[0003.394] W> Boot logo display failed…
[0003.397] I> Kernel EP: 0x80800000, DTB: 0x80000000

U-Boot 2016.07-gd917e08cec (Aug 12 2019 - 21:16:16 -0700)

TEGRA186
Model: NVIDIA P2771-0000-500
DRAM: 7.8 GiB
MC: Tegra SD/MMC: 0, Tegra SD/MMC: 1
*** Warning - bad CRC, using default environment

In: serial
Out: serial
Err: serial
Net: eth0: ethernet@2490000
Hit any key to stop autoboot: 2 1 0
MMC: no card present
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:1…
Found /boot/extlinux/extlinux.conf
Retrieving file: /boot/extlinux/extlinux.conf
733 bytes read in 156 ms (3.9 KiB/s)
L4T boot options
1: primary kernel
Enter choice: 1: primary kernel
Retrieving file: /boot/initrd
5565090 bytes read in 471 ms (11.3 MiB/s)
Retrieving file: /boot/Image
34244616 bytes read in 854 ms (38.2 MiB/s)
append: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 video=tegrafb no_console_suspend=1 earlycon=uart8250,mmio32,0x3100000 nvdumper_reserved=0x2772e0000 gpt usbcore.old_scheme_first=1 tegraid=18.1.2.0.0 maxcpus=6 boot.slot_suffix= boot.ratchetvalues=0.2031647.1 bl_prof_dataptr=0x10000@0x275840000 sdhci_tegra.en_boot_part_access=1 quiet

Flattened Device Tree blob at 80000000

Booting using the fdt blob at 0x80000000
reserving fdt memory region: addr=80000000 size=10000
Using Device Tree in place at 0000000080000000, end 0000000080058a73

Starting kernel …

[ 0.000000] Booting Linux on physical CPU 0x100
[ 0.000000] Linux version 4.9.140-tegra (qy@service-host) (gcc version 7.3.1 20180425 [linaro-7.3-2018.05 revision d29120a424ecfbc167ef90065c0eeb7f91977701] (Linaro GCC 7.3-2018.05) ) #3 SMP PREEMPT Tue Sep 10 15:16:09 CST 2019
[ 0.000000] Boot CPU: AArch64 Processor [411fd073]
[ 0.000000] OF: fdt:memory scan node memory@80000000, reg size 16416,
[ 0.000000] OF: fdt: - 80000000 , 70000000
[ 0.000000] OF: fdt: - f0200000 , 185600000
[ 0.000000] OF: fdt: - 275e00000 , 200000
[ 0.000000] OF: fdt: - 276600000 , 200000
[ 0.000000] OF: fdt: - 277000000 , 200000
[ 0.000000] earlycon: uart8250 at MMIO32 0x0000000003100000 (options ‘’)
[ 0.000000] bootconsole [uart8250] enabled

[ 0.520812] pca953x 0-0074: failed reading register
[ 1.031923] tegra-xusb-padctl 3520000.xusb_padctl: failed to setup XUSB ports: -517
[ 1.090780] tegradc 15210000.nvdisplay: dc_hdmi_hotplug_init: couldn’t get regulator vdd_hdmi_5v0, -517
[ 1.341622] FAN: coudln’t get the regulator
[ 1.622551] tegra-xusb-padctl 3520000.xusb_padctl: failed to setup XUSB ports: -517
[ 1.644348] tegra-xusb-padctl 3520000.xusb_padctl: failed to setup XUSB ports: -517
[ 1.658549] tegra-xusb-padctl 3520000.xusb_padctl: failed to setup XUSB ports: -517
[ 2.109635] cgroup: cgroup2: unknown option “nsdelegate”
[ 2.573927] tegra-xusb-padctl 3520000.xusb_padctl: failed to setup XUSB ports: -517
[ 2.659107] tegra-xusb-padctl 3520000.xusb_padctl: failed to setup XUSB ports: -517
[ 3.781468] random: crng init done
[ 3.784876] random: 7 urandom warning(s) missed due to ratelimiting
[ 3.974580] tegra-xusb-padctl 3520000.xusb_padctl: failed to setup XUSB ports: -517
[ 4.000160] tegra-xusb-padctl 3520000.xusb_padctl: failed to setup XUSB ports: -517
[ 4.016823] tegra-xusb-padctl 3520000.xusb_padctl: failed to setup XUSB ports: -517
[ 4.578811] tegra-xusb-padctl 3520000.xusb_padctl: failed to setup XUSB ports: -517
[ 5.415999] vdd-1v8: voltage operation not allowed
[ 5.420880] sdhci-tegra 3440000.sdhci: could not set regulator OCR (-1)
[ 5.449540] vdd-1v8: voltage operation not allowed
[ 5.454522] sdhci-tegra 3440000.sdhci: could not set regulator OCR (-1)
[ 5.482338] vdd-1v8: voltage operation not allowed
[ 5.487248] sdhci-tegra 3440000.sdhci: could not set regulator OCR (-1)
[ 5.496934] vdd-1v8: voltage operation not allowed
[ 5.501816] sdhci-tegra 3440000.sdhci: could not set regulator OCR (-1)
[ 5.653513] vdd-1v8: voltage operation not allowed
[ 5.658398] sdhci-tegra 3440000.sdhci: could not set regulator OCR (-1)
[ 5.666830] vdd-1v8: voltage operation not allowed
[ 5.671669] sdhci-tegra 3440000.sdhci: could not set regulator OCR (-1)
[ 5.679792] vdd-1v8: voltage operation not allowed
[ 5.684611] sdhci-tegra 3440000.sdhci: could not set regulator OCR (-1)

Ubuntu 18.04.4 LTS tx2 ttyS0

tx2 login:

Can you analyze the cause of the USB abnormality?

Can someone analyze this problem?

Can you analyze the cause of the USB abnormality?

Since I was new to jetson tx2, I can’t solve the current problem, please give me some suggestions

I do not have the ability to specifically figure out this problem, but do realize that power rails are also part of USB, and that not only would the wiring need to exactly match for USB, the power rails related to USB would also need to match. And then you would need to make sure the device tree related to those power rails and USB match.

If you are not familiar with device trees, then think of this as a uniform method of providing details of wiring to the kernel without the kernel itself needing to be written specifically for every single vendor and configuration. To illustrate, consider that long ago a PC had to have physical address jumpers manually set, and then the drivers had to be specifically told to use those addresses. Later, when plug-n-play came out, the devices themselves had a standard mechanism to allow the bus to ask the add-on peripheral what it was and to tell it among its configurations what to set up. The device tree is in some very loose way a half way between the old methods and the plug-n-play devices. Drivers can consult the device tree to know which address to use, what to enable, what to disable, what to put in some alternate mode, which drivers are allowed to talk to that device, so on. Device trees provided to drivers are the final step in drivers taking ownership of a device at an address.

Device trees are fairly simple, and lots of docs available on the topic. If you are not sure if your device tree is correct, then this is the best place to start. Browse around in “/proc/device-tree/”, as this is a reflection of the final device tree as presented to the drivers. Make sure your power rails and other USB-related content is correct.

If the module can work normally on dev kit with same sw, then it must be the issue of your carrier board. First of all, your board should be able to guarantee the power on sequence is correct (listed in OEM DG) which can make the system power on normally. You should use scope to measure the sequence. And then you need to make sure the USB part circuit design has no problem by comparing to that of dev kit based on design guide.

Using a homemade carrier board, the HDMI output is normal. But the SD card and USB d power enable EN are not output. What could be the reason?

What’s the use of EPROM on the carrier board? Isn’t it possible to design the carrier board by yourself?

There is a power monitoring circuit on the designed carrier board. How do I check the result of power monitoring and how to judge whether the circuit is normal?

Is your question same to this one: USB cannot be used on Non-public plate ?

Yes, we are experiencing the same problem. At present, HDMI is normal, indicating that the power-on sequence should be okay, and the pins are the same. We think that there is a problem with IN3221 monitoring, but there is no way to solve it at present. Are there any conditions for USB boot, such as detecting the correct 5V, etc.?

Please check that topic then.