using jetson nano to run docker container jupyter/minimal-notebook

Hi,
I am trying to build and run docker containers on my jetson nano. However, something seems not to be set up correctly, and I get error messages.

I set up the jetson nano as described in nvidia.com/jetsonnano-start. As the JetPack comes with docker, I don’t need to install it. When executing

$ docker run jupyter/minimal-notebook

the image is pulled as expected, but then I get the error message

standard_init_linux.go:211: exec user process caused "exec format error"

When building a docker file based on the minimal-notebook, the docker command WORKDIR works, but upon execution of RUN, I get the same error message. docker run hello-world and docker container run alpine echo “Hello World” work nicely.

[I already posted this on SO: https://stackoverflow.com/questions/57926729/docker-on-nvidia-jetson-nano-not-executing but since found out I don’t have to install docker]

Has anyone seen and solved a similar issue?

Hi,

The “exec format error” indicates that you are using an x86 image on the ARM system.
Please noticed that our docker doesn’t support x86-based images on the Jetson yet.

To setup a nvidia docker on Jetson, you will need to use container l4t-base:r32.2.
Here is our tutorial for your reference:
https://github.com/NVIDIA/nvidia-docker/wiki/NVIDIA-Container-Runtime-on-Jetson

Thanks.