Using nvidia-docker/ Docker 19.03.5 - GPU detection issue

When using this combination - results in error in the installer.py ““docker does not have nvidia runtime. Please add nvidia runtime to docker or install nvidia-docker. Exiting…””

Looking at the installer.py it appears it is not setup correctly, I have updated this file and posted at - https://github.com/prabindh/parabricks-changes/blob/master/installer.py

Diff can be seen at - https://github.com/prabindh/parabricks-changes/commit/b39f61b8512240bd8c3e7a903f09326fb029893f#diff-46ebfff5dd24618c5421e4f8292ea9e8

Can someone confirm this issue / change ?

Thank you for your interest in Parabricks.

native docker gpu support was added from docker 19.03. Parabricks will be supporting native integration of gpu during installation in the upcoming version of Parabricks due to release soon. For the time being, in order to overcome this, you may use nvidia-docker2 and docker 18.06.