Using UART0 - Disabling debug console

Hi all, I’m after some help disabling the debug console on /dev/ttyS0 in order to use the UART0 connection on J21 normally. The board is currently running on the R28.1 software. I’ve read through several posts on the forums, and it seems that in order to use the UART0 connection, I first have to disable the debug console. This is usually done in the extlinux.conf file, but that option is now loaded from the DTB file. However I can’t seem to get a correct DTB file to load in. Using FDT in the extlinux.conf doesn’t seem to have any effect, as when I view the device tree from /proc/, the settings have not changed. I’ve tried replacing and editing the .dtb files in /boot/, but that had no effect. I’ve also tried reading directly from /dev/mmcblk0p15 and that always seems to be empty. Is there anything that I’m missing in loading in a new DTB file? If possible I’d like to be able to make all these changes directly from the jetson board, as it is currently mounted in an inconvenient location.

hello geoffchannon,

please refer to this wiki page to update the device tree correctly for R28.1, https://elinux.org/Jetson/TX2_DTB#R28.1
thanks

Thanks Jerry, I can now flash the DTB, however I still cannot use the ttyS0 port. When I run

cat /proc/cmdline

on the jetson, it still shows console=ttyS0 in there, however I removed it in both my new DTB file and the .conf file. Are there other locations that bootargs are loaded in from to check?

I couldn’t tell you where, but U-Boot itself probably has this in its environment (and might be passing it on).