V4l2src caps not working, not able to stream camera

I am trying to stream a GMSL camera that is connected to my Xavier NX through a deserializer to USB3 board.
The camera shows up on the list of devices, nvarguscamerasrc does not see the device so I tried with v4l2src but I can’t seem to find a gstreamer command that lets me stream it.
This is the camera information that I can retrieve:

$ v4l2-ctl -d /dev/video3 --list-formats-ext
	Index       : 0
	Type        : Video Capture
	Pixel Format: 'YUYV'
	Name        : YUYV 4:2:2
		Size: Discrete 1936x1100
			Interval: Discrete 0.033s (30.000 fps)

I tried

gst-launch-1.0 v4l2src device=/dev/video3 ! 'video/x-raw, format=(string)YUYV, width=(int)1936, height=(int)1100, framerate=(fraction)30/1' ! videoconvert ! xvimagesink -e

which does not work and returns this error

WARNING: erroneous pipeline: could not link v4l2src0 to videoconvert0, neither element can handle caps video/x-raw, format=(string)YUYV, width=(int)1936, height=(int)1100, framerate=(fraction)30/1

I tried using only a few of the caps but the result is the same.
The only thing that worked so far for me is this command:

gst-launch-1.0 v4l2src device=/dev/video3 ! xvimagesink -e

which returns a green image, so there is still something wrong with it

Anyone able to help? I need to be able to stream this camera and encode an H265 video file

You may try format YUY2 in gstreamer for V4L format YUYV 4:2:2.

I just tried this now

gst-launch-1.0 v4l2src device=/dev/video3 ! 'video/x-raw, format=(string)YUY2, width=(int)1920, height=(int)1080, framerate=(fraction)30/1' ! videoconvert ! xvimagesink -e

The good news is that now it doesn’t complain about the caps anymore, the bad news is that the image still looks green as before

Does your camera supports 1920x1080 ? You may try1936x1100@30fps.

I restarted the Jetson and tried as you suggested

gst-launch-1.0 v4l2src device=/dev/video3 ! 'video/x-raw, format=(string)YUY2, width=(int)1936, height=(int)1100, framerate=(fraction)30/1' ! videoconvert ! xvimagesink -e

It still doesn’t work. It’s even weirder now, none of the commands that I used before work. Gstreamer opens a window but there is nothing in it, only a sort of “screenshot” of my desktop. There is no error message shown on the terminal and it stops only when I interrupt with Ctrl-C

You may post the output of failing commands for better advice. Add -v (verbose) to gst-launch-1.0 so that it tells what it is trying.
Is any of video0 to 2 another USB camera ? If yes, you may try without other USB cam.
Check with lsusb -t what speed gets your camera, when booting with or pluging after boot.
You may also try to use io-mode=2 as v4l2src plugin property.