vGPU and Tensorflow

Dear all,
I am trying to run tensorflow based programs on a VM Windows10. I don’t manage the installation so that tensorflow sees the GPU.

The card is a NVIDIA Tesla P40, Hypervisor VMware ESXi, 6.7.0, 8169922
The VM has GRID-P40-24Q with driver 411.81 that works with CUDA 10.0

I installed CUDA 10.0 and VisualStudio 2017, compiled the sample deviceQuery and when I run it the GPU is recognized and the output of the command looks like this:

CUDA Device Query (Runtime API) version (CUDART static linking)
Detected 1 CUDA Capable device(s)
Device 0: "GRID P40-24Q"
  CUDA Driver Version / Runtime Version          10.0 / 10.0
  CUDA Capability Major/Minor version number:    6.1
  Total amount of global memory:                 24576 MBytes (25769803776 bytes) 

Installation of python 3.7 and tensorflow-gpu 1.14.0 worked. However when I query tensorflow if a GPU is found I get FALSE. The AVX2 comment seems more to be connected to the CPU only so it is probably not the issue.

import tensorflow as tf
2020-08-24 18:13:24.728448: I tensorflow/core/platform/] Your CPU supports instructions that this TensorFlow binary was not compiled to use: AVX2

Overall I think that CUDA and vGPU are working but that the tensorflow is not able to access it.
Do you have a suggestion of what I can do?



After I posted the issue I tried it a last time by taking care that all versions match correctly and finally it worked.

So it was all a question of versions of tensorflow and CUDA matching together. I also did reinstall tensor-flow not using conda

pip tensorflow-gpu==1.14.0