VIC pulled down the frame rate from Argus API

The pipeline I used tegra_multi_media_api:

argus api -> VIC.

When I test with argus api only I can get 30fps rate from the log, but when I tried to combine the argus with encoder or VIC, I can not get the 30fps, mostly I got the frame rate low than 22fps.

argus + VIC…

Total Profiling time = 4.64235
Average FPS = 20.4638
Total units processed = 96
Average latency(usec) = 3391
Minimum latency(usec) = 1500
Maximum latency(usec) = 8370

argus + ENC… from 10_camera_recording sample

----------- Element = enc0 -----------
Total Profiling time = 99.8054
Average FPS = 14.9992
Total units processed = 1498
Average latency(usec) = 68904
Minimum latency(usec) = 387
Maximum latency(usec) = 78960
-------------------------------------
************************************
Total Profiling Time = 0 sec

How to get close to 30fps?

Have you boost the system clock by jetson_clocks.sh to try.

Hi, ShaneCCC

Yes, I tried “sudo bash jetson_clocks.sh”.

Still can not reach 30fps.

Hi Allen,
Do you run r28.2.1? What is the resolution? We’ve verified 10_camera_recording with onboard camera ov5693 in 1080p30. If it is not sensor-specific, we should observe the same with ov5693.

Hi, DaneLLL

Sorry for the late response.

For the sensor OV4689, we got the incorrect settings, so the frame rate are lower than 30fps.