FPS Drop after Running ARGUS

I tried v4l2 command to check the fps of my camera,

v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=RG10 --stream-mmap --stream-count=1 -d /dev/video0 --stream-to=ov5693.raw --set-ctrl bypass_mode=0

I got 60ps
then used the following command to get output in ARGUS.

gst-launch-1.0 nvarguscamerasrc ! nvvidconv ! xvimagesink

After that I ran the same v4l2 command but only getting 30fps

but after rmmod and insmod the module I am getting 60fps again
so i tired using the following command to see if it happens again

gst-launch-1.0 nvv4l2camerasrc ! nvvidconv ! xvimagesink

then tried the v4l2-ctl but the fps was not affected, the fps was affected only while using nvarguscamerasrc

Add framerate=(fraction)60/1 like below to confirm it.

gst-launch-1.0 nvarguscamerasrc ! 'video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080, format=(string)NV12, framerate=(fraction)60/1' ! nvvidconv ! xvimagesink
1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.