visionworks-1.6-samples issue

hello
i build this repository and when i run ./nvx_sample_object_tracker_nvxcu -s device://camera0
with jetpack 4.1.1 and logitech c930e ihave this error :

./nvx_sample_object_tracker_nvxcu -s device://camera0
Can’t open source URI device://camera0

can any one help me please !!

Hi,

Suppose it should work like this:

$./nvx_sample_object_tracker_nvxcu --source="device:///v4l2?index=0

Would you mind to give it a try?

Thanks.

thanks Aastall for your reply.
but i have the same error when i run

$./nvx_sample_object_tracker_nvxcu --source=“device:///v4l2?index=0”
Can’t open source URI device://v4l2?index=0

thanks Aastall for your reply.
but i have the same error when i run

$./nvx_sample_object_tracker_nvxcu --source=“device://v4l2?index=0”
Can’t open source URI device://v4l2?index=0

Hi,

Thanks for your update.
We will check this and update more information with you later.

Thanks.

Hello,
I have the same issue. My camera is in /dev/video0 but code

./nvx_sample_object_tracker_nvxcu --source="device:///v4l2?index=0"

gives following error:

Can

Is there any known solution?t open source URI device:///v4l2?index=0

Is there any known solution?

Hi,

We are still checking on this.
Will update more information with you later.

Thanks.

Hi,

Confirm this with our internal team:
VisionWorks doesn’t support USB camera but only CSI camera (camera attached to board).

Thanks.

Hi,

After internal discussion, it’s possible to update the source code for v4l2 on your own.
(Sorry that we don’t have the bandwidth to support this.)

The v4l2 camera is working in our previous VisionWorks version but fails recently due to some change in the GStreamer.
The change requires you to input the detail width/height/format of the camera.

You can try to update the source inside nvxio to make the V4L2 camera works.
Here is a working pipeline for your reference:

gst-launch-1.0 v4l2src device="/dev/video0" ! \ "<b>video/x-raw, width=640, height=480, format=(string)YUY2</b>" ! \ xvimagesink -e"

Thanks.

Hi

Thanks AastaLLL for your generosity and help.
But,i’m bigener in this fild . Can you tell me how and where can i add this pipline.

thanks.

hello everyone,

are there any updates on this?

thank you

I used this to make my usb camera workin Gstreamer

gst-launch-1.0 v4l2src ! “video/x-raw, width=640, height=480, format=(string)YUY2” ! xvimagesink

This worked for me:

In file /nvxio/src/NVX/FrameSource/GStreamer/GStreamerCameraFrameSourceImpl.cpp

Change line 139
< stream << “video/x-raw, format=(string){RGB}, width=[1,” << configuration.frameWidth <<

stream << "video/x-raw, format=(string){<b>YUY2</b>}, width=[1," << configuration.frameWidth <<

And add in line 217 your image output size
< std::string caps_string(“video/x-raw, format=(string){”);

std::string caps_string("video/x-raw, <b>width=(int){640}, height=(int){480},</b> format=(string){");

Hi Michael. Can I ask you after that editing and compiling, what would be the correct command line? I’m still getting errors.

Thanks a lot.

Sorry to bother you guys, but this is not working. I have e-con systems quad csi camera and even modifying the source code it won’t work.

I can get the web cam working. Thx.
But “Objects were lost” easy even if I just move the object slowly. Is there any better object tracking example? Thx