visionworks nvx_sample_player

Hello, When i run the application nvx_sample_player, the error occurred : “Cant’t open source URI /home/ubuntu/VisionWorks-1.4-Samples/bin/…/data/cars.mp4”.
And ./nvx_sample_player -s /home/ubuntu/Videos/test.mp4 too .

Thanks.

Hi Renbo,

Have you confirmed your camera work before tried to run the application nvx_sample_player?

Are you running the nvx_sample_player with the following command line:

nvx_sample_player -s device://camera0

Thanks

I think it doesn’t need camera when i play the file source.

I run the application nvx_sample_player with the command line “nvx_sample_player -s device://camera0” , it also occurred error : Cant’t open source URI device:camera0.

Thanks.

After reinstalling the system via the JetPack for L4T, it’s normal.

Thank You @kayccc

hello
i have this error.

./nvx_sample_player -s device://camera0
VisionWorks library info:
VisionWorks version : 1.6.0
OpenVX Standard version : 1.1.0

Error: Can’t open source URI device://camera0

Hi,

It looks like you already file a new topic specified for your issue:
https://devtalk.nvidia.com/default/topic/1051019/jetson-agx-xavier/visionworks-1-6-samples-issue/

Let’s track the following progress on the new topic.
Thanks.