Visionworks samples error due to source URI issue

I cannot successfully run the Visionworks sample that are included with Jetpack 4.2.1. I am compiling them on the Jetson Nano after a fresh install/sd card flash of the “jetson-nano-sd-r32.2-2019-07-16” image.

When I try and run the compiled samples, the all error out with the error:

Error: Can't open source URI /home/ale/Documents/visionworks/VisionWorks-1.6-Samples/bin/../data/cars.mp4

I get the same error even if I try and hard code the path to the assets in the source file.

Maybe the FrameSource object is failing at loading the sample media files.

Is there a fix that I’ve missed to get these sample up and running?


Could you setup the following value and try it again?

export DISPLAY=:1



export DISPLAY=:0


Im also getting the same error.
VisionWorks library info:
VisionWorks version : 1.6.0
OpenVX Standard version : 1.1.0

Error: Can’t open source URI /home/dlinano/VisionWorks-1.6-Samples/bin/…/data/signs.avi

I tried export DISPLAY=:1,
after that i m getting these error.
what is the issue with that source URI

Duplicated with Running Visionworks samples