VPI package not found

Hello,

I try to install VPI and use the nvidia guide (https://docs.nvidia.com/vpi/installation.html), but it doesn’t work. I using an Ubuntu 18.04.6 LTS on a Jetson Nano.

After sudo add-apt-repository ‘deb https://repo.download.nvidia.com/jetson/x86_64 bionic r34.1’ I get the following warning:

W: Skipping acquire of configured file ‘r34.1/binary-arm64/Packages’ as repository https://repo.download.nvidia.com/jetson/x86_64 bionic InRelease’ doesn’t have the component 'r34.1 (component misspelt in sources.list?)

Further, I do sudo apt update (Step4) and get the same warning. If I go to step 5, I get the error, that is unable to locate packages.

E: Unable to locate package libnvvpi2
E: Unable to locate package vpi2-dev
E: Unable to locate package vpi2-samples

It’s nice to be know, what I did wrong and I’m very thankful if you help me.

Beste regrads

Christian

I have the same problem on AGX Xavier, Jetpack 4.6 and Ubuntu 18.04.6 LTS:

W: Skipping acquire of configured file 'r34.1/binary-arm64/Packages' as repository 'https://repo.download.nvidia.com/jetson/x86_64 bionic InRelease' doesn't have the component 'r34.1' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'r34.1/i18n/Translation-en' as repository 'https://repo.download.nvidia.com/jetson/x86_64 bionic InRelease' doesn't have the component 'r34.1' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'r34.1/binary-arm64/Packages' as repository 'https://repo.download.nvidia.com/jetson/x86_64 bionic InRelease' doesn't have the component 'r34.1' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'r34.1/i18n/Translation-en' as repository 'https://repo.download.nvidia.com/jetson/x86_64 bionic InRelease' doesn't have the component 'r34.1' (component misspelt in sources.list?)

By looking at Index looks like repository link needs to be adjusted to specific device and release version, e.g. for AGX Xavier (T194) this could be:

sudo add-apt-repository 'deb https://repo.download.nvidia.com/jetson/t194 bionic r32.6'

but it doesn’t work either:

Get:4 https://repo.download.nvidia.com/jetson/common r32.6 InRelease [2555 B]
Get:5 https://repo.download.nvidia.com/jetson/t194 r32.6 InRelease [2547 B]        
Hit:6 http://ports.ubuntu.com/ubuntu-ports bionic-backports InRelease              
Err:7 https://repo.download.nvidia.com/jetson/t194 bionic Release
  404  Not Found [IP: 23.59.250.97 443]
Hit:8 http://ports.ubuntu.com/ubuntu-ports bionic-security InRelease
Reading package lists... Done                     
E: The repository 'https://repo.download.nvidia.com/jetson/t194 bionic Release' does not have a Release file.

Any hints?

Moving to the Jetson Nano forum

Hi, vanny132

Do you want to install VPI on a desktop machine or Jetson Nano?
The instruction is for an x86_64 environment.

For Nano, you should get the VPI preinstalled after setting up with the SDK manager
Or you can install it with sudo apt install nvidia-vpi directly.

Please also note that VPI v2.0 is included for JetPack 5.0 DP users.
However, JetPack 5.0 DP does not support Jetson Nano.

Thanks.

Hi, michal.kierzynka

JetPack 4.6 is r32.6.
The command is for JetPack 5.0 DP users.
If you want to use VPI 2.0, please upgrade your software with JetPack 5.0 DP first.

Thanks.

Yes that works, but if I develop a python script like

import vpi

print('Hello World!')

I get an error, that wasnot find a module named “vpi” :(
How can I solve that?

Hi,

We can import vpi without any error.
Could you check the installation and share the log with us first?

$ apt show cache nvidia-vpi

Thanks.

Hi, I do have the same error. I have all the VPI files in the installation folder but I can’t import VPI module in Python.

Result of the “apt show cache nvidia-vpi” command is given below.

I am using Jetson Nano 4GB

######################################################

Package: nvidia-vpi

Version: 4.5.1-b17

Priority: standard

Section: metapackages

Maintainer: NVIDIA Corporation

Installed-Size: 199 kB

Depends: libnvvpi1 (= 1.0.15), vpi1-dev (= 1.0.15), vpi1-samples (= 1.0.15), vpi1-demos (= 1.0.15)

Homepage: http://developer.nvidia.com/jetson

Download-Size: 29,3 kB

APT-Manual-Installed: yes

APT-Sources: https://repo.download.nvidia.com/jetson/t210 r32.5/main arm64 Packages

Description: NVIDIA Vpi Meta Package

N: Unable to locate package cache

N: Unable to locate package cache

N: There is 1 additional record. Please use the '-a' switch to see it

I can run the VPI demo for remap function when I click on “VPI Demos v1.0” icon on the desktop. But as i said, Python3 and Python2.7 can’t see that the VPI is installed. VPI module doesn’t show up on the list of all modules when checked.

Hi,

It seems that the VPI python packages are not installed in your environment.
Below is the output from our side for your reference.
You can find there is a python-vpi1 and python3-vpi1 packages.

$ apt show cache nvidia-vpi
Package: nvidia-vpi
Version: 4.6.2-b5
Priority: standard
Section: metapackages
Maintainer: NVIDIA Corporation
Installed-Size: 199 kB
Depends: libnvvpi1 (= 1.2.3), vpi1-dev (= 1.2.3), vpi1-samples (= 1.2.3), vpi1-demos (= 1.2.3), python-vpi1 (= 1.2.3), python3-vpi1 (= 1.2.3)
Homepage: http://developer.nvidia.com/jetson
Download-Size: 29.3 kB
APT-Sources: https://repo.download.nvidia.com/jetson/t194 r32.7/main arm64 Packages
Description: NVIDIA Vpi Meta Package

Please noted that the VPI python support is added recently.
Could you update your environment into JetPack 4.6.2 and try it again?

Thanks.

Thank you for the reply, as you said it was a JetPack version error. I fixed it by upgrading to version 4.6.2

Thanks for the update.
Good to know it works now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.