Error installing nvidia-jetpack

I get an error when installing with 【sudo apt install nvidia-jetpack】:
developer@developer-desktop:~/Desktop$ sudo apt install nvidia-jetpack
Reading package lists… Done
Building dependency tree
Reading state information… Done
nvidia-jetpack is already the newest version (5.1.1-b56).
The following packages were automatically installed and are no longer required:
apt-clone archdetect-deb bogl-bterm busybox-static cryptsetup-bin
dctrl-tools dpkg-repack gdal-data gir1.2-timezonemap-1.0 gir1.2-xkl-1.0
grub-common libaec0 libarmadillo9 libarpack2 libavresample-dev
libavresample4 libcfitsio8 libcharls2 libdap25 libdapclient6v5
libdc1394-22-dev libdebian-installer4 libepsilon1 libevent-core-2.1-7
libevent-pthreads-2.1-7 libexif-dev libfreexl1 libfyba0 libgdal26
libgdcm-dev libgdcm3.0 libgeos-3.8.0 libgeos-c1v5 libgeotiff5 libgl2ps1.4
libgphoto2-dev libhdf4-0-alt libhdf5-103 libhdf5-openmpi-103
libhwloc-plugins libhwloc15 libilmbase-dev libjbig-dev libkmlbase1
libkmldom1 libkmlengine1 liblept5 liblzma-dev libminizip1 libnetcdf-c++4
libnetcdf15 libodbc1 libogdi4.1 libopencv-calib3d4.2 libopencv-contrib4.2
libopencv-dnn4.2 libopencv-features2d4.2 libopencv-flann4.2
libopencv-highgui4.2 libopencv-imgcodecs4.2 libopencv-imgproc4.2
libopencv-ml4.2 libopencv-objdetect4.2 libopencv-photo4.2 libopencv-shape4.2
libopencv-stitching4.2 libopencv-superres4.2 libopencv-video4.2
libopencv-videoio4.2 libopencv-videostab4.2 libopencv-viz4.2
libopencv4.2-java libopencv4.2-jni libopenexr-dev libopenmpi3 libpmix2
libpq5 libproj15 libqhull7 libraw1394-dev libsocket++1 libspatialite7
libsuperlu5 libsz2 libtesseract4 libtiff-dev libtiffxx5 libtimezonemap-data
libtimezonemap1 liburiparser1 libvtk6.3 libxerces-c3.2 libxnvctrl0 odbcinst
odbcinst1debian2 os-prober proj-data python3-icu python3-pam rdate tasksel
tasksel-data
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 311 not upgraded.
5 not fully installed or removed.
Need to get 0 B/5,548 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: dependency problems prevent configuration of nvidia-l4t-jetson-multimedia-
api:
nvidia-l4t-jetson-multimedia-api depends on nvidia-l4t-camera (= 35.3.1-2023031
9081403); however:
Package nvidia-l4t-camera is not installed.

dpkg: error processing package nvidia-l4t-jetson-multimedia-api (–configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup erro
r from a previous failure.
No apport report written because the error message ind
icates its a followup error from a previous failure.
No apport report written bec
ause the error message indicates its a followup error from a previous failure.
No
apport report written because MaxReports is reached already
dpkg: dependency pro
blems prevent configuration of nvidia-jetpack-runtime:
nvidia-jetpack-runtime depends on nvidia-l4t-jetson-multimedia-api (>> 35.3-0);
however:
Package nvidia-l4t-jetson-multimedia-api is not configured yet.
nvidia-jetpack-runtime depends on nvidia-l4t-jetson-multimedia-api (<< 35.4-0);
however:
Package nvidia-l4t-jetson-multimedia-api is not configured yet.

dpkg: error processing package nvidia-jetpack-runtime (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-jetpack:
nvidia-jetpack depends on nvidia-jetpack-runtime (= 5.1.1-b56); however:
Package nvidia-jetpack-runtime is not configured yet.

dpkg: error processing package nvidia-jetpack (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-jetpack-dev:
nvidia-jetpack-dev depends on nvidia-l4t-jetson-multimedia-api (>> 35.3-0); how
ever:
Package nvidia-l4t-jetson-multimedia-api is not configured yet.
nvidia-jetpack-dev depends on nvidia-l4t-jetson-multimedia-api (<< 35.4-0); how
ever:
Package nvidia-l4t-jetson-multimedia-api is not configured yet.
nvidia-jetpack-dev depends on nvidia-jetpack-runtime (= 5.1.1-b56); however:
Package nvidia-jetpack-runtime is not configured yet.

dpkg: error processing package nvidia-jetpack-dev (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
nvidia-l4t-jetson-multimedia-api
nvidia-jetpack-runtime
nvidia-jetpack
nvidia-jetpack-dev
E: Sub-process /usr/bin/dpkg returned an error code (1)

Before installing I have run 【sudo apt update】.

And I type 【sudo apt show nvidia-jetpack】 to see the output:
developer@developer-desktop:~/Desktop$ sudo apt show nvidia-jetpack

[sudo] password for developer:

Package: nvidia-jetpack

Version: 5.1.1-b56

Priority: standard

Section: metapackages

Maintainer: NVIDIA Corporation

Installed-Size: 199 kB

Depends: nvidia-jetpack-runtime (= 5.1.1-b56), nvidia-jetpack-dev (= 5.1.1-b56)

Homepage: http://developer.nvidia.com/jetson

Download-Size: 29.3 kB

APT-Manual-Installed: yes

APT-Sources: https://repo.download.nvidia.com/jetson/common r35.3/main arm64 Packages

Description: NVIDIA Jetpack Meta Package

I have no idea what you are doing.
The first part of the log already told you that nvidia-jetpack had been installed, then why you were trying to remove it?

Anyway, try stuff like sudo apt -f install.

On my first install, he reported the error
E: Sub-process /usr/bin/dpkg returned an error code (1) and so on, so I tried to reinstall and still got these errors.

So sudo apt -f install does not work?

Yes, I eventually solved the problem using the following command:
sudo apt-get install --reinstall nvidia-l4t-camera=35.3.1-20230319081403
sudo apt-get install --reinstall nvidia-l4t-jetson-multimedia-api
sudo dpkg --configure -a
sudo apt-get install nvidia-jetpack
Thanks for the answer.

1 Like