vs2010 sdk sample projects "unavailable" Problem with GPU SDK 4.0 on Windows 7 x64

Hello,
I installed GPU Computing SDK 4.0 on Windows 7 x64. When I open a sample solution (doesn’t matter if it is CUDA, OpenCL or DC) in Visual Studio 2010 Professional it says:
“One or more projects in the solution were not loaded correctly. Please see the Output Window for details.”

Output window for each project says:
C:\Users\nikola\AppData\Local\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.0\C\src\dct8x8\dct8x8_vs2010.vcxproj : error : The imported project “C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\BuildCustomizations\CUDA 4.0.props” was not found. Confirm that the path in the declaration is correct, and that the file exists on disk. C:\Users\nikola\AppData\Local\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.0\C\src\dct8x8\dct8x8_vs2010.vcxproj

I checked the folder “C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\BuildCustomizations” and actually the file “CUDA 4.0.props” is not there, and it isn’t anywhere else on the disk. I uninstalled and reinstalled the sdk many times, even with administrator rights, but it is always the same.

Thanks for any help.

That’s a bit hard to diagnose - are you sure all the components got installed? Also, this post might be of interest to you, although in general if you don’t have the .props file then I don’t know… http://blog.cuvilib.com/2011/02/24/how-to-run-cuda-in-visual-studio-2010/

Many thanks for the reply. I’ve already seen that post and other about previous versions of the sdk, but I’ve also read that 4.0 should work on vs2010 (at least non-express versions) without any workaround. I don’t have vs2008 installed, but I think that the presence of CUDA 4.0.props shouldn’t depend on it.

in the project file, look for

or

replace with

<Import Project="$(VCTargetsPath)\BuildCustomizations\CUDA 4.0.props" />

I’m trying to open the SDK sample projects, and thay already have those lines. As I said in the first post the problem is that “CUDA 4.0.props” is not found when I open a project because it doesn’t get installed.

I saw that some users are having the same problem with the Spanish version of Win7, while I have the Italian version. Maybe it is a problem with non-english versions?
My “Program Files (x86)” folder is actually labelled “Programmi (x86)”, even though also paths with “Program Files (x86)” usually address it correctly.

I was having the same issue after installing the SDK, so I downloaded the CUDA toolkit (not the SDK) and installed that. It prompted me to uninstall the previous toolkit installation, so I went through all that and now it’s working (and CUDA 4.0.props is there).

To summarise:
Download the CUDA toolkit (http://developer.nvidia.com/cuda-toolkit-40)
Install the toolkit (uninstalling the SDK version when prompted)
???
Profit!

I installed CUDA Toolkit. It didn’t ask me to uninstall the already installed sdk, so I now have both sdk and toolkit, however now I can compile the sdk samples!
Thank you very much!

The errors

64 bit Machine: "The imported project “C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\BuildCustomizations\ CUDA 4.0.props” was not found.

32 bit Machine: "The imported project “C:\Program Files\MSBuild\Microsoft.Cpp\v4.0\BuildCustomizations\ CUDA 4.0.props” was not found.

occur because there are no “CUDA 4.0.props” files there, as already mentioned in the first post.

This usually happens when:

a) CUDA Toolkit is not installed, or
Solution: Install the CUDA toolkit

b) You installed Visual Studio after installing the toolkit.
Solution: Uninstall the CUDA toolkit and then re-install it. Should take care of the issues.