VSync issues/Tearing in KWin with composite enabled

Hi,

Has you know (here and here) there is tearing with Kwin, for more than year at least, if you simply enable composite. Only setting __GL_YIELD=“USLEEP” avoids this.

So it would be wonderful if this issue can be fixed and I think a lot of people will be happy if you can give us an update on the situation.

Thank you.

The proper solution is to enable triple-buffering.

Section “Device”
Identifier “Device0”
Driver “nvidia”
Option “TripleBuffer” “1”
EndSection

in your /etc/X11/xorg.conf file.

Ok I tried and it works good.
Thank you very much.

So is there a bug in Nvidia driver or Kwin ?

Age old Kwin bug.
https://bugs.kde.org/show_bug.cgi?id=322060

I didn’t read all the comments but the status of the bug report is UNCONFIRMED.
I speak with some people on Netrunner forum here who says that is a Nvidia bug.

So I don’t know what is true and it will be good if some Nvidia “official” can answer.

The status doesn’t mean much. Thomas Lübking who is a KDE dev is on this for a year now and merges nvidia vsync bug reports into this one.