Vulkan not supported on GT520 ?


According to docs of driver install GT520 is not listed ? So I am guessing GT520 is not supported ? Why not ? Is it too slow ? Or is there a “valid” technical reason :)

I try to start Wolfenstein on my PC and then it crashes:

(Looking at the log it’s starting to make sense to me… the VK letters in the executable name… maybe there is a none-vk version… hmm unfortunately no none-vk version is present… hmmm.

Anyway to fix this and to get it run ? 1 to 5 FPS would still be acceptable ;)

Perhaps something else might be wrong… I have seen games detect GT520 as DX8 card… while in reality it’s DX 9 and 10 and even 11… so could be a software problem… and probably is…

Is there any beta driver that perhaps does include GT 520 support ?

Winsock Initialized
idCommonLocal::Init() time 20: 0.018s
------ Initializing File System ------
Current search path:
- C:/Users/Skybuck/SAVEDG~1/MachineGames/Wolfenstein II The New Colossus/base/
- C:/Games/Wolfenstein II The New Colossus/base/
------ File System initialized.
WARNING: ReadJsonFile: could not read file: packagechunklist.json
Executing build.cfg…
------ Command Line ------
“C:\Games\Wolfenstein II The New Colossus\NewColossus_x64vk.exe”
------ CPU Information ------
1 CPU package, 2 physical cores, 2 logical cores
2009 MHz AMD CPU with MMX & SSE & SSE2 & SSE3
65536 kB 1st level cache, 524288 kB 2nd level cache, 0 kB 3rd level cache
4096 MB System Memory
idCommonLocal::Init() time 30: 0.024s
idLib::SetProduction( PROD_PRODUCTION )
idCommonLocal::Init() time 40: 0.225s
------- Initializing renderSystem --------
…registered window class

Application Info

App : Wolfenstein II The New Colossus - 1.0.2
Engine : idTech - 6.5.0

Instance Extensions

  • VK_KHR_surface
  • VK_KHR_win32_surface
  • VK_KHR_get_physical_device_properties2
    WARNING: No address, error: 126
    WARNING: No address, error: 126
    WARNING: No address, error: 126
    ? @ 0x40a2c40d( ) + bytes () : ** UNKNOWN **( ** FUNC_PARAM_ERROR ** )
    ? @ 0xfffffffe( ) + bytes () : ** UNKNOWN **( ** FUNC_PARAM_ERROR ** )
    ? @ 0x044af670( ) + bytes () : ** UNKNOWN **( ** FUNC_PARAM_ERROR ** )
    FATAL ERROR: vkEnumeratePhysicalDevices failed with error (VK_ERROR_INITIALIZATION_FAILED)
    TIMER: idRenderSystemLocal::Init() took 675.3470 ms
    Dumped console text to C:\Users\Skybuck\SAVEDG~1\MachineGames\Wolfenstein II The New Colossus\base\ErrorLog_10-28-2017__08-51-49pm.txt.

log file ‘qconsole.log’ opened on Sat Oct 28 20:51:49 2017

CrashHandler: Storing data and writing local report.
WARNING: No address, error: 126
idStackTracer::GetSource: Failed


Hi This is not a reply, more like a cry for help. I am having the same problem with my GTX 560. I am getting the exact same crash error msg. I have tested this on 3 different copies of the game,(My bought copy, and 2 downloaded pirated copies from 2 VERY reputable sources. nothing works I’ve tried every version of driver for my card(7 different ones) with a clean install and reboot after each. I have tried to install Vulcan SDK and the runtime libraries, nothing seems to work. will there be a fix/patch/update for this issue???

I have the same problem with my GT620. These cards have a Fermi architecture and Fermi currently doesn’t have Vulkan support. Back in 2016, NVIDIA said they weren’t planning on adding it too, but I hope that if we let NVIDIA know there’s lots of people that want Vulkan on Fermi, they’ll change their minds.