Warping fails on driver version > 460.91, Blending still works

Hi,
I have a dome projection setup with 4 projectors connected with 4 dvi cables each to 4 identical Dell Precision workstations with Quadro P5000 cards running Ubuntu 20.04. I adapted the nv-control-warpblend code to read my own warp matrix and blend image to apply the corrections according to the camera based calibration. This worked very well until I updated the driver to 495.44 from the graphics-drivers ppa. Since then only the blending image is applied to the image but not warp matrix. To verify the behaviour I cloned nvidia-settings repository, compiled the code and tried the nv-control-warpblend executable but with no success: the blend image is applied but the image remains unwarped. Due to the hight resolution each projector is connected with 4 dvi cables to the graphics card and each projector appears as 4 screens with 1024x2400 pixel resolution. For debugging purpose only 3 screens of the projectors are connected while the 4th is output is connected to a normal monitor. Each of the screens is warped and blended separately and the warpmatrix and blend image must be split accordingly. As said, up to version 460.91.03 this works very well.
Unwarped Desktop (left), correctly warped (driver version 460.91.03, center), only blended (driver version 495.44, right):


I already posted an issue on the nvidia-settings github repository (GitHub - NVIDIA/nvidia-settings: NVIDIA driver control panel) where the XNVCtrl API and corresponding examples can be downloaded. Can anybody confirm this error and knows how to fix it or whom to contact?

Cheers,
HellG

Since the nvidia-settings github repo is maintained by aplattner, I guess the correct nvidia officials should know.
Furthermore, this
https://forums.developer.nvidia.com/t/does-warp-blend-work-on-quadro-k4000/190444
looks like it’s been an issue with the Windows drivers as well and is being addressed.

The issue on Windows with driver 466 has been verified and it should be fixed also in the linux driver 470.86 (see Problem with WarpBlendSample.exe on Quadro k4000). However it does not work for drivers 495.44 and the thread is closed.

Dear @HellGL

Thanks for tagging the relevant thread. I will go through your problem description and forward it to the correct team. Please give us some time for the internal investigation.

Thank you.
NVIDIA Forum Moderator

Any update on this issue?

Dear @HellGL

The concerned team has read through your problem description and has filed a bug internally. An engineer is already assigned to it. Kindly allow some more time for the investigation to complete. I will get back to you once I have any significant update.

Thank you.
NVIDIA Forum Moderator

Hello,
i have the same issue in Ubuntu 20.04, drivers 470.86 and NVidia Quadro P1000, but with drivers 460.91.03 it works.
please help us.

Thank you

Dear @RobertoAlda
Thanks for reaching out to us. We will need some more time to fix this issue due to other higher priority feature commitments. I will post any updates in this thread.

Thank you.
NVIDIA Forum Moderator

Hi, any news on this issue?
I really need to solve this problem, please let me know when it will be fixed.
Thank you.

Is this bug present also in NVIDIA A2000 videocard?

We have been able to root caused the issue, fix will be incorporated in future driver release.

I can confirm that the warping is working with the new driver (515.48) on Ubuntu 20.04.

Thank you very much for fixing the problem.

Thanks HellGL for the update, we will make this thread as closed now.

I also confirm that the new drivers solve the warping problem with my T1000.
Thank you so much for fixing this bug!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.