Weird problems in compiling

Hi all,

You may have seen this post before. But I and my friends have been tried to solved this problem, still have no idea what’s wrong.

Here’s the problem.

I have Geforce8400GS installed, also CUDA and VS 2005. When I compile a project from SDK, I got the following errors:

1>------ Build started: Project: histogram64, Configuration: Debug Win32 ------

1>Performing Custom Build Step

1>histogram64.cu

1>Command-line error: invalid option: --compiler_bindir

1>1 catastrophic error detected in this compilation.

1>Compilation terminated.

1>Linking...

1>LINK : fatal error LNK1181: cannot open input file '.\Debug\histogram64.obj'

1>Build log was saved at "file://c:\Program Files\NVIDIA Corporation\NVIDIA    CUDA SDK\projects\histogram64\Debug\BuildLog.htm"

1>histogram64 - 1 error(s), 0 warning(s)

========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

I am using the cuda.rules. After I read “The CUDA Compiler Driver NVCC”, my understanding is -ccbin will be considered the same as --compiler-bindir. But in my error, it is --compiler_bindir instead of --compiler-bindir. And no matter how do I change the command line from the rule file, I would get the same error, I even hard code “nvcc -cuda histogram64.cu --compiler-bindir=D:\Program*\Microsoft*\VC\bin -keep -dryrun” in the command line . I doubt if VS is really reading from it.

The demos can be runned, btw.

We have tried everything we can. Almost desperate :( If anyone could offer any help we will appreciate a lot!!!

Thanks!!!

I can not help you with vs2005 setup, but for me the simple instal worked well.
CUDA 1.1 toolkit
CUDA SDK 1.1
VS2005 express ( free download )
nv8600GT
winXP

try this(works for me):

cmd.exe

cd “C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\projects\histogram64”

nvcc.exe -link -ccbin “C:\Program Files\Microsoft Visual Studio 8\VC\bin” -DWIN32 -D_DEBUG -D_CONSOLE -Xcompiler “/EHsc /W3 /nologo /Wp64 /Od /Zi /MDd /GR” -I"C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\common\inc" -I"C:\CUDA\include" -L"C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\common\lib" -LC:\CUDA\lib\ -lcutil32 --opencc-options -LIST:source=on -keep histogram64.cu histogram64_gold.cpp

do not forget to have required DLL in your app’s directory:

copy “C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\common\lib\cutil32.dll” .

and run :
a.exe

Thanks, .m. . I move the graphics card to another computer, and it works there. So it must be some system setting problems in the previous one.