What Driver/CUDA version for 840m Optimus? 396.26 won't work!

Hello-

I encountered an error installing CUDA 9.2 on my laptop. It’s a Dell Latitude E7450 with a GeForce 840M Optimus chipset, and I’m running CentOS 7.5. Originally, I tried to install CUDA against the drivers that are available via ELREPO (390.67). That did not work- I kept getting errors about the driver version not being new enough. After doing some searching I found this thread (1), where txbob indicated that CUDA 9.2 needs to use the drivers bundled with the CUDA code.

I began by removing the drivers I got via ELREPO.

I then downloaded and un-archived cuda-linux.9.2.88-23920284.run. I killed X and logged in at a console prompt. Tried to install the driver and kernel modules I unpacked from the CUDA download. The driver installer advised me that it could not find any compatible hardware!

Going back to the NVIDIA driver download page, I selected the driver for Linux 64bit 840M. I noted that the driver it had me download was 390.67.

Are there any known bugs with 396 that make the 840M not detectable?

Thanks!
-JK

(1) https://devtalk.nvidia.com/default/topic/1035692/cuda-setup-and-installation/ubuntu-16-04-cuda-9-2-with-driver-390-59-insufficient-driver-/post/5270518/#5270518

by choosing a “beta” driver, this R396 driver specifically lists 840M as supported:

http://www.nvidia.com/download/driverResults.aspx/133859/en-us