Cuda 9.2 won't work on Centos 7 with driver 390.59

I’m on a Centos 7 machine trying to get Cuda 9.2 to run. When I run the deviceQuery, I get “CUDA driver version is insufficient for CUDA runtime version”, and when I run a simple program I get a segmentation fault.

After trying various things all morning, I uninstalled the previous version (installed via RPM), reinstalled an NVidia driver, then installed Cuda 9.2 using the run file. My Xserver wouldn’t start, so I downloaded and installed the latest NVidia driver (390.59), and the Xserver starts, but Cuda won’t work. I saw a post that said "use the driver that came with Cuda 9.2, but I have two problems with that.

First, HOW do I use that driver?

Second, will it work, because when I installed Cuda it broke my Xserver (or something–all I know is that the actual machine came up with either a blank screen or an error screen), and I assume it was using that driver. And is there a difference between using that driver for Cuda programs and using that driver for the Xserver?

Please help. I’m lost.

Is your Xserver using the NVIDIA GPU for display purposes, or some other GPU?

is this a laptop?

In any event, CUDA 9.2 requires a R396 driver (396.xx) and will not work with a a R390 driver (390.xx)

I’m actually not sure what my computer is using for display purposes. It’s a 24-core machine with an nVIDIA GeForce GTX750. In any case, I downloaded and installed the 396.xx driver, rebooted, and everything seems to be working now. Thanks! I thought the “long term” one would be better (the 390.xx one), but I guess not.