When i Run the installation procedure Through --sudo python3 install.py--

i am getting error like this-----
Traceback (most recent call last):
File “install.py”, line 17, in
import trt_pose.coco
File “/usr/local/lib/python3.6/dist-packages/trt_pose-0.0.1-py3.6-linux-aarch64.egg/trt_pose/init.py”, line 1, in
import torch
File “/home/scientech/.local/lib/python3.6/site-packages/torch/init.py”, line 195, in
File “/home/scientech/.local/lib/python3.6/site-packages/torch/init.py”, line 148, in _load_global_deps
ctypes.CDLL(lib_path, mode=ctypes.RTLD_GLOBAL)
File “/usr/lib/python3.6/ctypes/init.py”, line 348, in init
self._handle = _dlopen(self._name, mode)
OSError: /usr/lib/aarch64-linux-gnu/libgomp.so.1: cannot allocate memory in static TLS block
------------plese help me

Hi @amit.iot2022, can you try running export LD_PRELOAD=/usr/lib/aarch64-linux-gnu/libgomp.so.1 in your terminal first?

yeah, i tried but it gave same error

ok, i got it after some other research -----
add this in your bashrc file ---- export LD_PRELOAD=/usr/lib/aarch64-linux-gnu/libgomp.so.1 ------ and save the file
and excute this line — source .~/bashrc
and i add this in my code in starting -----
from torch.nn.utils.rnn import pad_sequence
and it work
Thank you

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.