Why simulation becomes slow when increasing min simulation frame rate

I increased min_simulation_frame_rate and time_step_per_second from 30 to 400 to match the controller’s caculation rate, and the control system did work better, but I noticed that the simulation scene run much slower than real time physical environment, which has bad effects on control. Can anyone help me with that?


With this you are setting just the simulation frame rate to 400hz and telling the simulation to step just once. So the simulation wont match with the UI thread.
So you have two options:
a) set the min_simulation_frame_rate back to 30, this means several simulation steps will be done with the frequency 400hz to match up to 30hz UI frequency.
b) lock the UI thread to 400hz too, this can be done in edit->preferences->rendering

Hope that helps, regards

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.