Why USB in my carry board of Jetson TX2 doesn't work

Hello, I am using Jetson TX2. I designed a carry board for Jetson TX2. But The usb3.0 doesn’t work in my carry board. I plug in usb devices, but no any logs with dmesg command for the USB devices.The board is L4T 28.1. Please see attached USB schemetic in my carry board.
I measured the enable pin from chip.There is no enable signal in that pin even though I plug in some usb devices.So the vbus voltage is always 0.
Could you help check the problem?Is it hardware issue or software issue? Should I change some config such asthe dtb file for my customed board?

Update the information.The pin “USB1_EN_OC” in Jetson tx2 is always low.So the vbus in usb module is 0 voltage.The hardware is same with original Jetson TX2 board design.The software is also same with Jetson tx2.Why voltage in pin “USB1_EN_OC” is always low even though I plug in a usb device?

PLease check
https://developer.nvidia.com/embedded/dlc/jetson-tx2-tx2i-oem-product-designguide


https://elinux.org/Jetson/TX2_USB

Thank you. I will try.
One more question, could you tell me what is different between “vdd_usb2_5v” and “battery_reg” and “spmic_sd3”? What do these words mean?
- vbus-2-supply = <&vdd_usb2_5v>;
+ vbus-2-supply = <&battery_reg>;

./nvidia/platform/t18x/common/kernel-dts/t18x-common-platforms/tegra186-cvb-prod-p2597-b00-p3310-1000-a00-00.dtsi:              vdd_usb2_5v: regulator@17 {
./nvidia/platform/t18x/common/kernel-dts/t18x-common-platforms/tegra186-quill-power-tree-p3310-1000-a00-00.dtsi:                vbus-2-supply = <&vdd_usb2_5v>;
vdd_usb2_5v: regulator@17 {
			compatible = "regulator-fixed-sync";
			reg = <17>;
			regulator-name = "vdd-usb2-5v";
			regulator-min-microvolt = <5000000>;
			regulator-max-microvolt = <5000000>;
			gpio = <&gpio_i2c_0_74 0 0>;
		};

vdd_usb2_5v is a gpio expander pin on default carrier board. Usually it is removed in custom board.
battery_reg is system power.

@DaneLLL I tried your suggested method as described on the web page.
I change the hardware/nvidia/platform/t18x/common/kernel-dts/t18x-common-platforms/tegra186-quill-power-tree-p3310-1000-a00-00.dtsi as below:

pinctrl@3520000 {
vbus-0-supply = <&vdd_usb0_5v>;
vbus-1-supply = <&vdd_usb1_5v>;
- vbus-2-supply = <&vdd_usb2_5v>; ====<<==delete this line
+ vbus-2-supply = <&battery_reg>; ====<<==add this line
vbus-3-supply = <&battery_reg>;
vddio-hsic-supply = <&battery_reg>;
avdd_usb-supply = <&spmic_sd3>;
vclamp_usb-supply = <&spmic_sd2>;
avdd_pll_erefeut-supply = <&spmic_sd2>;
};

The USB(J19) still doesn’t work. There is no any message even though I plug into a usb stick or other usb devices in to USB(J19) after I change that dtsi and rebuild and burn it with flash.sh.
But intresting thing is the mini usb(J20) works after I change the dtsi.

Could you please give me any suggestion about why USB(J19) doesn’t work?
I attached the USB(j19) schematic for your reference.
Thanks a lot.
OUR_J19.png

@DaneLLL

Hi DaneLLL,

Beside the change above I also made following change:
replace Linux_for_Tegra\bootloader\t186ref\BCT\tegra186-mb1-bct-pmic-quill-p3310-1000-c03.cfg in
https://developer.nvidia.com/embedded/dlc/l4t-jetson-tx2-driver-package-27-1

But the USB3(J19) still doesn’t work.Could you help check it?

I also attached boot log for my jetson tx2 board.Please have a look.Thank you.
boot_log_usb.txt (59.8 KB)

What is USB config of your custom board? You have to change device tree per USB config accordingly.