WiFi connection randomly stopped working

I have a 2GB Jetson Nano with the Lincukoo WiFi dongle that came alongside it in the bundle. I flashed JetCard using the Getting Started guide, then installed JetRacer and assembled my Waveshare Pro AI Kit. Everything was working perfectly - I could access the Jupyter Lab interface through the proper IP, same with the WiFi through the IP found in ifconfig. Then suddenly this morning I was tunkering further with my AI car and after turning the servomotor to on, I can no longer connect to Jetson through WiFi.

I’ve tried restarting, turning the servo to off like yesterday (when it worked!), disconnecting and connecting to the WiFi again, turning power saving off on wlan0, all to no avail. The IP is correct but when I try to connect through it, I only get the Jupyter favicon loaded but then it keeps spinning and the blank white page never proceeds to the actual Jupyter Lab.

Why on earth can this be happening and how can I combat this? Sometimes the WiFi list only shows the network it’s currently connected in, sometimes all that are actually available but regardless, it does not allow to connect anyway :(

EDIT: now it randomly worked again. But that’s the thing - it’s all random and unpredictable right now :(

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

  1. What is the mode of this WIFI now? Do you make it as a access point or it is in STA mode?

  2. It is possible to share us the dmesg and syslog (/var/log/syslog) from your device after the wifi fails? Please also tell us the timestamp of when this error happens. Otherwise it is hard to check the syslog.