Jetson Nano Instantly Disconnects with TP-LINK WN722N from WiFi

Hi there, I have been trying to connect my Jetson Nano to my home WiFi using the TPLINK WN722N. The USB WiFi adapter was able to scan for nearby WiFi. I tried connecting to my home WiFi as usual by selecting it in the WiFi available list then Key-ed in my password. The system loaded for a bit and after about 5 seconds or so, it says I’m disconnected from my home WiFi. I’m able to see from my router that the 722N attempted a connection.

I had tried to disable power_save “sudo iw dev wlan0 set power_save off”. But the result is the same. The Jetson Nano I’m running is a fresh install, running, R32, Revision 5.1.

I would kindly like some help on this. Thanks in advance :D.

After another day of tinkering with the device, I found out that my router was the issue. To give more insight into my setup, I’m using a TP-Link Deco M4 Nest router. The 722N (AR9271], which didn’t need any additional driver installation, connects perfectly when I used my Samsung S10e as a WiFi bridge between my Deco and it.

Glad to know issue resolved, thanks for the update!