Windows 10 code 43 error Quadro 600

hi, I have two graphics cards K600 and 600 on a dell t1600 system.

I updated to windows 10, updated latest drivers from nvidia and graphics card driver reported error code 43 on installed Quadro 600. In windows 7 both cards work fine.

I uninstalled the drivers and installed again several times. Still getting error.

Is there any way to fix the error?

Thanks in advance
600.gif

I’m not an expert on this as windows 10 is pretty new, but the new WDDM model in windows 10 imposes some nuances on behavior of NVIDIA GPU devices from architecturally different generations (i.e. in systems with certain mixed GPU configurations.)

Your Quadro 600 is a Fermi device, and currently only has WDDM 1.3 support via NVIDIA drivers (this will change in the future).

Your Quadro K600 is a Kepler device and currently has WDDM 2.0 (i.e. the new WDDM in win 10) support.

The latest drivers currently are from the R352 branch. To use both Fermi and Kepler devices in the same Win 10 system CURRENTLY it is recommended that you use a driver from the R340 branch. This is a WDDM 1.3 driver and will work correctly in win 10 both for Kepler and Fermi devices.

In the future (probably later this year) I expect NVIDIA will release drivers that allow the usage of Fermi devices in WDDM 2.0 mode.

For example, this R340 driver is compatible with both Q600 and QK600, and should allow you to use both devices in Win10:

http://www.nvidia.com/download/driverResults.aspx/84585/en-us

Note that there are more details to this that I haven’t covered. The behavior will vary depending on which GPU is enumerated as primary by the system. In your case, I suspect the K600 is being enumerated as primary. But nevertheless the advice to use R340 will allow both devices to work.

Thank you very much!! I’m happy to report that I did what you said and it’s working fine now. You’re a lifesaver!!

Hello. I have an NVidia Geforce GT630 Graphics card, and after installing the latest 353.62 drivers I still get the Code43 error. I see the fixes you have been suggesting appear to be for laptops. What can I do to get this card working again?

I have a similar problem. I run dual Titan-X cards in SLI. I recently acquired a GTX470 from a friend which I was going to use for PhysX. If I install this card (it works fine by itself), it gives me the error 43 code (I’ve done a clean driver install), and also causes my secondary Titan-X to give the same error, effectively breaking SLI. If I remove the 470, SLI works again. All 3 cards are known good.

@RanXerox Without more details about your system config, I doubt I can offer any suggestions. The most important question is if you have more than one NVIDIA GPU.

Anyway, the fix discussed here in this thread (which has nothing to do with laptops) involves not loading the latest R352 drivers, so you don’t seem to have grasped that.

@druuzil since you don’t mention anything about driver versions, I’m not sure anyone can help you.

THE GIST of all this is that if you have multiple NVIDIA GPUs that come from both Fermi and Kepler generations, for now you need to use an R340 driver. If you want help, you need to list all the GPUs you have, and all the driver versions you’ve tried. And if you haven’t tried an R340 driver, you should probably do that before posting any further.

Do you think any previous generation driver will work? How do you tell if it’s WDDM 1.3 or 2.0?

I am using the latest Nvidia driver.

Under R340, both Fermi and Kepler will run in WDDM 1.3 mode, which makes win10 happy.

Under R352, Kepler will run in WDDM 2.0 mode but Fermi will run in WDDM 1.3 mode, which makes win10 unhappy.

(presumably this will be fixed at some future date, in some future GPU driver version)

R340 = drivers whose versions are in the 340.xx - 341.xx range

R352 = drivers whose versions are in the 352.xx - 353.xx range

Kepler = GeForce 6xx, 7xx mostly (there are exceptions).
Fermi = GeForce 4xx, 5xx (again, there may be exceptions.)

If you think you have a config like this, please try an R340 driver that is listed as compatible with both or all of the NVIDIA GPUs in your machine.

Use the driver wizard at www.nvidia.com … Drivers

Yes, to use an R340 driver you have to select one from Win8.1 in the wizard, not Win10

Since there are no Windows 10 R340 series drivers, I’m about to test one from Windwos 8.1.

So, the driver installed and sure enough all 3 of my cards are now enabled. The problem is that it won’t let me enable SLI because 2 Windows processes are running that can’t be shut off/stopped.

ShellExperienceHost
SearchUI

The Shell process can be stopped but it just immediately restarts itself. SearchUI doesn’t even exist in the process tree so I have no idea how you’re supposed to even enable SLI now. It’d be great if the NVCP window that pops up telling you about conflicting processes (no idea why these processes stop SLI from enabling) could automatically end those processes for you.

So, basically you can either have SLI and no PhysX card, or you can have neither.

Edit

I found a walkthrough. You have to bring up task manager and NVCP, then kill Windows Explorer, which then allows you to kill those other processes. Then enable SLI, then restart Explorer.exe through your task manager.

I solved the problem on my 740M (so it seems), I uninstalled the drivers 355.60 and I tried to install the drivers mentioned in the other thread (the 341.61) with a clean install, but the problem has not been resolved. As it was late and I was bored, I disabled the video card from “Device Manager”, turned off the computer and went to bed. The next day I turned on the computer and reactivated the video card to do other test, like magic error 43 was gone and I tried to update drivers with Windows Update (installed 353.54), updated and apparently functional.

My thoughts:
I think I’ll go back to Windows 8.1 soon!

This is how I solved my code 43 error

I used Rufus to create a bootable flash drive with a linux OS (Xubuntu) on it. I then restarted my computer and accessed the boot menu. I selected to boot from the flash drive and proceeded to install Xubuntu. Only select install third party software, then hit continue. On the next screen when asked to erase disk select quit. Shutdown your computer and start up like normal. Your Code 43 error will be gone and the graphics card will be functioning again.

Below are the links to download Xubuntu and Rufus. Use Youtube to learn how to create a bootable flash drive using Rufus.

https://rufus.akeo.ie/

http://xubuntu.org/

hi when i checked my device manager i saw my display adapters i noticed that my nvidia geforce 740m Windows has stopped this device because it has reported problems. (Code 43) i already updated my drivers 355.82 its installed now but in my device manager is still the same HELP GUYS my laptop is x550lb ASUS HELP PLS

Yeah i have the same problem i have GTX 750ti and i have the newest drivers instaled nothing changed and i still get this mesage Windows has stopped this device because it reported problems. (Code 43) (sorry for my english)

I’m pretty close to having this fixed for me anyway… Need the last 10% though. Maybe someone has a bright idea. Once I figured out how to get things working initially the problem became Windows Update constantly overwriting the driver I deliberately installed. The windows option to prevent this did nothing.

It’s a Sager P170EM notebook with a Quadro K3000M and Intel HD 4000.

This is all documented elsewhere so I’ll paraphrase. I’m not an expert, not sure how much of this is necessary or what I was just doing because I read it on forums. My process went something like:

  1. Disconnect hard network connection and set WI-FI to metered.

  2. Delete existing driver.

  3. Safe mode reboot.

  4. Use Device Driver Uninstaller. Reboot.

  5. Install Windows 8 x64 driver 305.46 with clean install. This is the last driver that Sager packaged for the computer. 2012.

  6. Reboot.

  7. Download Windows 10 x64 341.92 driver from Nvidia’s site.

  8. Unzip the 341.92 .exe file.

  9. Install 341.92 driver by right clicking on the device in the device manager. Update driver -> Browse Computer to driver folder.

  10. Download and use Microsoft show or hide updates (wushowhide.diagcab) to hide the Nvidia update that keeps overwriting 341.92

  11. Enjoy the bliss of quadro.

Problem is that the next time I reboot the card will code 43. Then I have to do roll back the driver to 305.46, reboot, and then reinstall 341.92 via the Device Manager method to get it going again.

THANK YOU!!!

Man, thank you so much

I’m looking for a way to fix this error for a while
Not even system restoration worked

I didn’t donwload and install an older version

What I did:
I just disabled the card in device manager, turned off my notebook, turned it on and enabled the card
And it seems to be fixed

Did you have Nvidia Optimus features? and is it active from BIOS?

it looks like it need to be ‘Power Cycle’ after we install/reinstall/disable graphic card. So that OS recognized.

hi
i have a Quadro p600 and use in virtual machine
os in vm is win 7 64bit and install driver with pny cd
after install caution sign in graphic driver to device manager and error is "windows has stopped this device because it has reported problems.(code43)
Is there any way to fix the error?

Thanks for your time,and I hope to hear from you soon!